Nissan Frontier Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
On my 2000 xe 4 cyl. std. shift, all the gauges work great in the daytime and at night with the lights on... EXCEPT when the vehicle is in cruise control. Then, after a little while(at night only), the speedo goes all over, the tach all over, and the rest of the gauges pretty much go dead. If I take it out of cruise control, they all recover ok.
I know the simple solution, don't use cruise control at night. Is there any other simple solution if I do wanna use cruise control at night ??
The only other possible related symptom, is when the vehicle sits a long while, and is then run using the lights, it takes a while for the dash lights to illuminate. It seems if I use the dimmer alot and other accessories, the dash lights eventually come on.
I'm really stumped.:crying:
 

·
Premium Member
Joined
·
7,137 Posts
Check to ensure your taillights are functioning properly in all possible modes...running/parking/turning/braking/etc...
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
All taillight functions ok...just inspected. However I just cleaned ALL my grounds and cluster gauge lights operate fine on first start -up. Not sure of cruise control yet with lights on...my major problem.
 

·
Registered
Joined
·
337 Posts
I'm betting alternator, when they start pumping bogus voltages, gauges go whacko! Full disclaimer, this happened on the wife's 2003 mustang, hasn't happened with my frontier.
Can you use cruise control during the day, with out the lights on?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #5 ·
Thanks, I can use cruise control (all day) without light on, and works fine. I think the grounds can affect voltages too, so proceeding to clean those up. Good tip!
 

·
Premium Member
Joined
·
522 Posts
I don't know about gen 1 but gen 2 frontiers have a problem with lights on that the dual filament bulb can short from running light filament to the brake light filament. When this happens in gen 2 trucks it shuts down cruise control and cuts thottle because truck thinks brake has been applied, a short on brake wire to some voltage source can cause same indications, if this happens only with lights on check for brake light short.
 

·
Registered
2015 CC SL 4x4 - Lear Cap.
Joined
·
231 Posts
Assuming the cruise works as advertised, it sounds like a wiring issue in the steering column...
 

·
Registered
Joined
·
178 Posts
I've had other vehicles do the same thing.
Most turned out to be a bad ground.
Instead of searching for the ground, I spliced a ground to the ground wire for the cluster.
 

·
Super Moderator
Joined
·
3,691 Posts
Gen 1 instrument clusters are also notorious for having internal problems, usually due to cracked or broken solder joints. There are a number of companies, like Mr. Whizard, that repair them. They usually charge about $200, but there may be other companies that charge a little less.
 
1 - 10 of 10 Posts
Top