Nissan Frontier Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
400 Posts
Discussion Starter #1
took off my rads off and put my stock stuff back on and no more clunk
checked the PSI and its a little over 190lbs
only had them for about 5 months
light off roading just running on the beach no jumping
so now i have to send them back to get rebuilt
and yes i bought them new not to happy:pullout:
 

·
Registered
Joined
·
229 Posts
Right after I installed my Radflo 2.0's I got a slight clunk in my front end. I can even feel it through the floor. It's mostly noticeable at low speeds over small bumps or uneven pavement. It's really annoying. I hope it doesn't get worse over time.

Is this a common issue with Radflo's?
 

·
Registered
Joined
·
400 Posts
Discussion Starter #4
Around 200 to 250 psi
 

·
Registered
Joined
·
400 Posts
Discussion Starter #5
Right after I installed my Radflo 2.0's I got a slight clunk in my front end. I can even feel it through the floor. It's mostly noticeable at low speeds over small bumps or uneven pavement. It's really annoying. I hope it doesn't get worse over time.

Is this a common issue with Radflo's?
thats how mine started
 

·
Rogue Admin
2007 LE 4x4 Crew Cab Long Box
Joined
·
13,736 Posts
mine were pooched right away, too. but 190lbs couls be from letting out a little nitrogen when checking them. a small hiss is 5-10psi as the chamber is so small.
 

·
Registered
Joined
·
2,132 Posts
....but 190lbs couls be from letting out a little nitrogen when checking them. a small hiss is 5-10psi as the chamber is so small.
^+1...
OP. What bumpstops are you using on the LCAs? I had a "clunk"; found that I was mashing the stop on the Radflo shaft 1/4" before the LCA's did.
 

·
Registered
Joined
·
177 Posts
^+1...
OP. What bumpstops are you using on the LCAs? I had a "clunk"; found that I was mashing the stop on the Radflo shaft 1/4" before the LCA's did.
Do you mean the UCA? If you are talkin about the bottoms the stock bumstop isn't good? Is it supposed to be changed with radflo's? I'm havig a suspicion that my Radflo's are low also.
 

·
Rogue Admin
2007 LE 4x4 Crew Cab Long Box
Joined
·
13,736 Posts
to give you an idea of low, one of mine was at 90psi. the schraeder valve was leaking. radflo said they had a bad run of valves and o rings. so a $0.25 part was to blame. go figure.
 

·
Registered
Joined
·
3,545 Posts
Do you mean the UCA? If you are talkin about the bottoms the stock bumstop isn't good? Is it supposed to be changed with radflo's? I'm havig a suspicion that my Radflo's are low also.
no he means the LCA, as the bump stop is on the LCA and contacts the bracket welded to the frame.

There is a droop pad on the prg arms for when you droop out your truck and the arm contacts the coil bucket. Or if you put stupid preload on your coils and have no down travel they hit all the time to. But then your truck just rides like poop, and makes all kinds of noise. Looks good in the mall though:laugh:
 

·
Registered
Joined
·
1,280 Posts
Dang man, get it all squared away and see you at the next meet...who knows, I might take the ten pack off your hands if u haven't gotten rid of them yet.
 

·
Registered
Joined
·
400 Posts
Discussion Starter #12
my knock sounded like a bad ball joint and only knocked at low speeds over small bumps
 
1 - 13 of 13 Posts
Top