Nissan Frontier Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
24 Posts
Discussion Starter · #1 ·
Hello everyone. Just bought an 06 Frontier LE last week. Love the truck and still getting used to everything.

Yesterday I decicded to try out some of the MP3 player features and fear that I may have hosed my radio. I burned two cds; one with nothing but MP3 songs and another with directories on it. The one with nothing but MP3s played fine, but the one with folders caused the CD player to lock up. It never read the CD and simply stated 'press eject' on the display. Upon pressing eject it returned me to the radio.

If I press the CD button it tells me that there is not a CD in the changer. I had it fully loaded with six of them, and had cd's 1-6 illuminated on the display, but now it only shows 1 and that one is flashing. Pressing eject or load does not get me anything. Every 20 seconds or so I can hear the mechanisim trying to load/unload a CD, but nothing happens.

After experiencing these issues, I looked at the CD on my PC to see if there were any burning issues and found that the first folder on the CD was unfortunately full of .wma files. I think the radio cannot read these and is confused as to what to do.

I have tried powering off the truck and just about every combination on the face of the radio.

Any suggestions? I live about 1 hour from the dealer... I am afraid I am going to have to get them to work on it.

Thanks in advance,

Mo
 

·
Registered
Joined
·
2,776 Posts
When you say you tried powering off the truck, did you disconnect the battery of just shut off the truck? If you didn't, try disconnecting the battery for about 15-20 minutes and turn on the head lights, this normally will drain any residual current off the system and reset most components. With any luck, it will have the same effect on your stereo and it will work fine afterwards. I doubt any physical damage occured as all it was doing was reading the CD. Let us know what happens!
 

·
Registered
Joined
·
345 Posts
You could be seeing something I saw about 2 years ago with my 6 disc changer...one of the CDs got stuck in the mechanism...it made this clicking sound every so often, and I couldn't get any of the CDs out.

I had to take it and they swapped out the changer for me...Then they sent my old changer to some repair facility, and I eventually got all my CDs back, although some of them were freaking scratched.

Good luck...
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #4 ·
Dang... hate to hear that about the scratched CD's. Luckilly I just burned all 6 of the ones I had in there. This is why I like to have...um backup copies of my music. ;)

Since my initial post this morning I read in the manual that this SHOULD play .wma files. So, I am starting to wonder if it is not that one of the CD's jumped off track. I have read quite a bit of that on the internet today. Seems Nissan's changers are notorious for it.

I will try the battery/power down thing this weekend. If it does not work I will take it to the shop next week.

I will let you all know the results.

Thanks again for your replies.

Mo
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #5 ·
So I tried removing the battery power (great idea by the way) and it was a no go. So I took it back to the stealership and I guess kilago was right. They are ordering me a new changer (radio) and will replace it next week.

They said I would get my cds in the mail from Fosgate. whadda trip.

I hope this is not going to be a continual thing.

Thanks for your help, everyone.

Mo
 

·
Registered
Joined
·
345 Posts
MoFro said:
So I tried removing the battery power (great idea by the way) and it was a no go. So I took it back to the stealership and I guess kilago was right. They are ordering me a new changer (radio) and will replace it next week.

They said I would get my cds in the mail from Fosgate. whadda trip.

I hope this is not going to be a continual thing.

Thanks for your help, everyone.

Mo
Well, glad you got it fixed. My changer broke after 2 years and 10 months...so it was good timing I guess because I got a new one right before warranty ended. haha...Anyway, maybe they can give you some freebies for your time...some Nismo goodies.
 

·
Registered
Joined
·
92 Posts
I was just looking at my manuel and it says that if you hold down the eject button for at least 5 seconds, that will tell the cd changer to eject all cd's. Try that, see if that does anything. If not, also try to select the cd that it indicates you have, "you said that it's full of cd's but it only shows one" and then hold again that eject button for 5 seconds and that command only eject that. Good luck. I have a question for you. How does your subs sound? My Frontier came with the Fosgate sytem too and I could barely hear the powered subs..
 

·
Registered
Joined
·
24 Posts
Discussion Starter · #8 ·
MACEONE... thanks for the suggestions. I have already had the dealer swap the radio for a new one. I did try every-friggin thing I could find in the manual, including the eject all feature. It did show CD #1, but it was flashing and would not let you select it. I cannot remember if I actually tried the combination of selecting that CD and hiting the eject button at the same time though.

As to your question of the subs; I cannot believe that you cannot hear yours? The sound quality of the stereo is quite subjective! But, I can still hear mine and feel that I get more quality than you would expect 2-6" subs to sound in a composite box. What levels do you keep the bass/mid/treble on? <-------- ******* I would actually like for anyone to answer this question. I know it is relative to the preferences of the listener, but have often wondered what others find sounds best to them.*****

I have mine set like this:

bass +1
Mid +3
Treble +3

I actually had my mid down to 2 and my treble up to 4, but I think the dealership screwed sumthin up again when switching my radio. I know all they have to do is simply unplug the harness and plug it back in, but now it sounds like my tweeters are blown? All the highs run together. I have adjusted and adjusted (was quite aware of where the levels were prior to the change) and I cannot get it to sound like it used to.

None the less, you should be able to hear your subs. I get a lot of bass sound from the 6x9's in the door, but can for sure tell a sub is in there on my dj magic mike feel the bass CD. Yes, I feel both gay and ghetto playing that in my truck, but have always used that CD for benchmark testing.
 
1 - 9 of 9 Posts
Top