Nissan Frontier Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello Again.
If im in the wrong section I do apologise.
My 06 navara d40 Aventura.
The 4wd on the dashboard is lite when its in 2 wd if you turn it to 4wd it flashes up a picture and shows it 4wd, 4 lo if you then turn it back to 2wd it flashes up the picture in 2wd and then goes out .Once it been turned of or used for a while the light comes on but its still in 2wd.
The nissan computer says its a switch fault but iv had 3 control switches in and it makes not a blind bit of difference.
Any ideas?
 

·
Premium Member
Joined
·
1,172 Posts
Hello Again.
If im in the wrong section I do apologise.
My 06 navara d40 Aventura.
The 4wd on the dashboard is lite when its in 2 wd if you turn it to 4wd it flashes up a picture and shows it 4wd, 4 lo if you then turn it back to 2wd it flashes up the picture in 2wd and then goes out .Once it been turned of or used for a while the light comes on but its still in 2wd.
The nissan computer says its a switch fault but iv had 3 control switches in and it makes not a blind bit of difference.
Any ideas?
What exactly is the problem? the "4x4" light, or the picture that indicates how many wheels you are getting power from? Sorry, just trying to understand a little better to help you out! I assume you are not under warranty anymore?
 

·
Registered
Joined
·
6 Posts
Discussion Starter #3
Top left of clocks is 4WD light , this says 4wd most of the time, If YOU CHANGE TO 4WD FROM 2WD THE LIGHT GOES OF THE PICTURE SHOWS 4WD.(SORRY ABOUT CAPS)Change back to 2wd from 4 picture shows 2wd no light. Drive around a mile light for 4wd comes on and picture goes of. Nissan machine said swith fault.Change the in cab switch no change , Where is the switch on the g/box. When the 4wd light does come on its still in 2wd it just lights the light. cheers Andy
 
1 - 3 of 3 Posts
Top