Nissan Frontier Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Just purchased a 2010 Frontier and after driving about 100 miles or so I kept noticing a strange rattle coming from near the front left wheel well when I was driving over bumpy roads. I could best describe it as sounding like a shock absorber casing was broken and was rattling around. I took it to the dealer and found out both side engine mounts were defective. They had to order the parts so it was a few days later when they fixed it but they said the truck was still drivable. The truck seems all OK now.

Aloha
Bobby B
 

·
Super Moderator
Joined
·
11,070 Posts
That's an odd failure for a brand new vehicle. Good to know it was diagnosed and repaired without frustrating you. Now go out there and drive the wheels off of it.

Clint
 

·
Registered
Joined
·
637 Posts
Weird, I wonder how they were defective? Did they show you the old parts?
 

·
Registered
Joined
·
8 Posts
Discussion Starter #4
Back In The Shop Again

Well the rattle problem started coming back in my 2010 Frontier. I would hear it when going like 5 to 10 MPH over bumpy roads.

The first time they replaced both side engine mounts.

So today this is what they said on the invoice.

"Found loud ticking noise coming from both side engine mounts area, found loudest noise coming from lower nut that mount the engine mount rubber to metal bracket. Loosen and lubricated before mount and bracket, noise is gone system is OK."

And its still 3 weeks away from my 3 month check up.
 
1 - 4 of 4 Posts
Top