Nissan Frontier Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
461 Posts
Discussion Starter · #1 ·
Driving home today doing 60mph or so I was going around a long corner and my car just decided to drift into the outside lane (almost). It wasn't the steering, but something weird in back. I didn't even think of looking at my gauge panel so I don't know if any lights came on.

So later on when I was going slower I noticed my diff lock and traction control lights come on like a disco. I was random, not really at the same time, but sometimes it was. Then they both stayed on for a few seconds and stopped. A few seconds later they started flashing again.

It did this in turns, straights, slow, fast, fwd, reverse, neutral and park. Rough and smooth.

This is a 2013 Frontier p4x.
Here's a video of what's going on.
https://www.youtube.com/watch?v=ZHqcWlBYJWc
 

·
Registered
Joined
·
461 Posts
Discussion Starter · #3 ·
Not sure where the diff fluid would go. It's dry as a bone from the cover to each wheel. No cei though. I looked at the wheels and they are clean, little dust, I don't do any mudding so not sure if the wheel sensors would be dirty.

Just booked an app with the dealer. I still have till Oct and 2,000km to go for warranty. Maybe I should have gotten the extended warranty. I didn't with this truck since my last one was perfect for 14 yrs.

I'll check the fluid anyway, don't have a reader, although my friend does. Pulling 16hr days the next three days. ugh. Was hoping for some fun on my birthday, but looks like I'm spending it at the dealer. lol
 

·
Registered
Joined
·
23 Posts
Mine did this too but after the diff and traction light disco they went solid and stayed that way for a few minutes before the abs, traction control and the tire slipping light came on. dealer found out it was a bad differential control unit and a bad locker button. don't know if that is what is happening with your truck but it could be leading to it and hasn't started setting off the other lights yet.
 

·
Registered
Joined
·
461 Posts
Discussion Starter · #5 ·
Interesting. This was the first time I ever saw it go on (except when the diff was actually on) or during winter snow and the traction control light would go on when I was not driving "responsibly".

My wife is driving the truck to work (she works like 2 miles away and I work 30). She said no lights on this morning on her way to work.

Thanks for the input.

I did a search and every thread remotely the same had the abs light on. I figured since it's not on, I'd start a new thread.

I had a phantom cruise control "issue" with my last truck. The cruise control light would go on randomly when I went through a deep puddle. Since I never use cruise control, I never cared. And, it had to be a deep puddle.

This kind of worries me since I also had a weird understeer kind of thing going on right before I noticed the lights. If the diff is indeed locking at highway speeds, I can't see the rear end lasting very long.
 

·
Registered
Joined
·
54 Posts
Driving home today doing 60mph or so I was going around a long corner and my car just decided to drift into the outside lane (almost). It wasn't the steering, but something weird in back. I didn't even think of looking at my gauge panel so I don't know if any lights came on.

So later on when I was going slower I noticed my diff lock and traction control lights come on like a disco. I was random, not really at the same time, but sometimes it was. Then they both stayed on for a few seconds and stopped. A few seconds later they started flashing again.

It did this in turns, straights, slow, fast, fwd, reverse, neutral and park. Rough and smooth.

This is a 2013 Frontier p4x.
Here's a video of what's going on.
Im having the same issue with my 2016 Pro4x, maybe @ZOMBIE KILLER or any other Tech on here can help shed some light.
Thx
 

·
Registered
Joined
·
667 Posts
I'm having the same issue with my 2016 Pro 4x. Hopefully @ZOMBIE KILLER or any other Tech can hel shed some light on the matter.
It could be a multiple of things but the most common that i seen is a ABS sensor that would turn both light's, but it would be a repairs that you would have to look at, it could be simple as contaminates on the sensor to a ABSA/DCM. Electrical and sound repairs are the worse.
 

·
Registered
Joined
·
420 Posts
Had a similar issue with a off road 2010 Xterra. Think I had abs, diff lock and traction ctl lighting and flickering. Happened after heavy rain.
Cleaned the diff lock switch connectors at the rear locker. Been awhile and not sure what made me look there. One thing I do remember is that you didn’t want to remove the switch from the diff, big pita to put back. Google your issue at the 2nd gen Xterra forum. Its one reason I went with a sv not pro 4x. Complexity leads to more potential for issues.
 
1 - 9 of 9 Posts
Top