Nissan Frontier Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
56 Posts
Discussion Starter · #1 ·
I have an 06 cc 4x4 6 spd. When i set the cruise control and try to accelerate with the steering wheel control it cancels the cruise control. It just started happening on a trip down to san diego(which sucked cuz i basically set it and forget it for that 5 hour trip). I swear it's going to be something stupid causing it, but i just keep overlooking it.

p.s. already tried searching it. no helpful results.
 

·
Super Moderator
Joined
·
11,161 Posts
I just looked at the service manual and without a consult II scanner there isn't much the consumer can do. We the owners are at the dealers mercy due to all the computer related systems.

Clint
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #3 · (Edited)
Well thats unfortunate. How much will they charge me to scan my truck. My closest friendly nissan dealer is in fresno which is 45 minutes from me.. not coool

Well thats unfortunate. How much will they charge me to scan my truck. My closest friendly nissan dealer is in fresno which is 45 minutes from me.. not coool.
I can still use it though. Just as soon as I accelerate using the control or I. Go up a small hill its cancels
 

·
Registered
Joined
·
6 Posts
The dealer is the best way to get it fixed, but there are quite a few things that can cause it. One thing I used to see pretty often is faulty or failing brake light switches causing them to cancel the cruise. Sometime if you have a friend behind you on the road ask if your brake lights ever come on when u aren't stepping on the pedal. As soon as they do it will cancel your cruise. Like I said though, lots of things can cause it. A leak in the vacuum lines, a bad connection, faulty TPS, ABS issues, one tire being really low on air, etc. Its not an easy one to find, even for the dealer.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #5 ·
ok so heres what i've come up with. I'm pretty sure the transmission fluid must be low. When i put it into gear the truck revs up pretty high and gradually starts taking off and every time i upshift(or downshift), it feels like there is no torque cuz it revs up ridiculously high again.
 

·
Registered
Joined
·
3,545 Posts
ok so heres what i've come up with. I'm pretty sure the transmission fluid must be low. When i put it into gear the truck revs up pretty high and gradually starts taking off and every time i upshift(or downshift), it feels like there is no torque cuz it revs up ridiculously high again.
Huh, you have a six speed? sounds like your clutch is toast.

The cruise will also kick out if you are pulling a hill in to high a gear.
 

·
Registered
Joined
·
56 Posts
Discussion Starter · #7 ·
yeah its a six speed. Yesterday I went on a trip up to sierra summit(3 hour trip with lots of 4 wheelin in the snow) and this morning I went out to do run to the store and i could barely get it to move without it revving up to about 6k. I'm droppin it off at the shop tomorrow and starting my clutch shopping now. Figure I might as well have a good strong clutch put in while im at it. We do a lot of 4 wheelin up in the mountains in the summer and winter for camping and snowboarding. Any quick thoughts on what type of clutch i should go for?
 
1 - 7 of 7 Posts
Top