Nissan Frontier Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
44 Posts
Discussion Starter #1
So my new-to-me used 2005 KC A/T V6 journey continues to be full of experiences. After finally getting the TCM working, all codes cleared, inspected and registered, I finally worked on some internal fixes (replaced radio dash). I had to take it apart and relocate the a/c cluster to the new panel - disconnecting my passenger airbag harness. I drove it around this weekend (filled up tank of gas - added seafoam injection cleaner, dropped off my oil to be recycled), came home, and did the clearing of the flashing air bag (3 secs on, remove key, etc). That worked fine, but when I started the truck, it would crank but not turn! Started by turning and died out shortly, then eventually only cranks but not turn.

Only thing I can think of is maybe damaging the ignition doing the relearn or the injection cleaner clogged up my fuel. Battery seems to be okay. No code. Replaced my driverside camshaft, and also crankshaft sensor - maybe the passenger camshaft went out after the other two went out? Other thing I am thinking is fuel pump - but am not sure why it would die all of the sudden (did the seafoam mess it up?). I don't have a fuel pump gauge, so any other method in testing that would be helpful.

Any thoughts would be appreciated. I'm kind of getting tired of these surprises and my wife keeps giving me the side-eye on my truck.

Thanks in advance - the forum has been a lifesaver thus far.
 

·
Registered
Joined
·
1,842 Posts
My guess would be failing or failed fuel pump.
 
1 - 2 of 2 Posts
Top