Nissan Frontier Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Replaced entire timing set, harmonic balancer, valve cover gasket, water and oil pump. Made sure everything was lined up correctly before installing, but now that everything is back together it cranks but wont start.
Truck ran fine before I started working on it. Has spark, fuel, and air
 

·
Registered
Joined
·
183 Posts
Replaced entire timing set, harmonic balancer, valve cover gasket, water and oil pump. Made sure everything was lined up correctly before installing, but now that everything is back together it cranks but wont start.
Truck ran fine before I started working on it. Has spark, fuel, and air
Need check basics.
Is fuel pump running?
Are injectors pulsing?
You check compression be sure you i didn't damage valves?
Cycle the key on and off several times be sure fuel rail hasn't bled off and air locked.
Remove the pcv vent hose form the upper plenum spray starting fluid in it, just to be determine the problem.
 

·
Registered
Joined
·
3,596 Posts
Check ignition timing, maybe you installed the distributor off a gear tooth or 3.
 
  • Like
Reactions: TxDayTrader

·
Registered
Joined
·
6 Posts
Discussion Starter · #4 ·
Need check basics.
Is fuel pump running?
Are injectors pulsing?
You check compression be sure you i didn't damage valves?
Cycle the key on and off several times be sure fuel rail hasn't bled off and air locked.
Remove the pcv vent hose form the upper plenum spray starting fluid in it, just to be determine the problem.
Pump running, it's getting fuel to all cylinders. I haven't checked the compression.
 
1 - 4 of 4 Posts
Top