Nissan Frontier Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
48 Posts
Discussion Starter #1
my clutch pedal isnt the same as when it was new. I have about 85k miles on it. the pedals travels alot further than it use to before it disengages. i basically let the pedal all the way out before i have to give it gas to start going. i've bleed the line. is there anything else it might be, the slave cylinder looks fine, doesnt look like its leaking or anything. any suggestions.
 

·
Registered
Joined
·
562 Posts
New clutch?
 

·
Registered
Joined
·
48 Posts
Discussion Starter #3
i had a car that the clutch was going out in, and it doesnt feel like that. kinda of like i need to adjust the pedal, but its a hydraulic clutch so i really cant, can i?
 

·
Registered
Joined
·
562 Posts
i had a car that the clutch was going out in, and it doesnt feel like that. kinda of like i need to adjust the pedal, but its a hydraulic clutch so i really cant, can i?
Could be the throw out bearing. I forgot what is was called.
I had the same problem with my Vibe Gt.
 

·
Registered
Joined
·
8,525 Posts
Are you clutch plates worn out? There is a member here that installed a new one. I know he drives a KC Black Frontier and he just spent a lot of money on parts but I can't remember his name. This may be your solution.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #6
I'll have to keep looking, ok now yesterday i was driving and 5th gear seemed like it would fully disengage the clutch when i was tryin to accelerate at a high speed. I was speeding up to get on the highway, and it was almost liked it reved and then caught, but i had taken my foot off the clutch. I hope its not the clutch, that cost money
 

·
Registered
Joined
·
61 Posts
Sounds like a clutch going out to me. I had a car that the clutch pedal had to travel almost all the way out before it engaged. Shortly after that when accelerating hard the engine reved up quickly even though I wasn't even on the clutch pedal.

Sorry man, but I think your clutch is going on ya. Better be easy on it and make it last as long as possible. I drove on mine like that for another 3-4 months, just couldn't drive it hard.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #8
i guess i'm in denial. all the signs are leaning towards the clutch going out. but damn if i want to pay to take it in, and damn if i want to do it myself.

Trade-in? haha
 

·
Registered
Joined
·
1,258 Posts
It's hard for my to say because I am an Auto and the clutches are not what they once were like in my 97 but the guys on here with 6 speeds say they suck. It sounds like to me (after driving a manual up untill my current) that your clutch is calling it quits.
 

·
Registered
Joined
·
1,161 Posts
I just ordered a centerforce yesterday. Mineisdoing the exactsamething: clutch engauges almost all the way up and in a higher gear it slips some what bad. I've been driving it this way for maybe month or so. As for the slave cylinder???? There is a group buy on right now for a JWT clutch and flywheel by the way.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #12
Guess I'm going to have to get a new clutch. I think its time for a whole make over. My serp belt is going now too. oh and the brakes are squeaking, I'm going to have a busy weekend.
 

·
Registered
Joined
·
398 Posts
Guess I'm going to have to get a new clutch. I think its time for a whole make over. My serp belt is going now too. oh and the brakes are squeaking, I'm going to have a busy weekend.
What clutch disc did you buy? Did you change the clutch yourself? Did a dealer do the work? Or, did you trade up?
 

·
Registered
Joined
·
3,327 Posts
We have 1 more spot open on the group buy for the clutch/flywheel package. It's $659. Let me know if you are interested.

I'll need your name, address, e-mail, and make/model sent through pm.
 

·
Registered
Joined
·
3 Posts
Clutch Issue

What year is frontier? I have a 2005 with 65K. My truck is doing the exact same thing where the revs jump and then everything catches back up. I have read a few places that the 05-06 models have issues with the clutches. I know the Z's do. They seem to be burning out early or in some cases the hydraulic pump may be going.

You had any luck in figuring out the issue with yours?
 

·
Registered
Joined
·
1,161 Posts
thtas typical clutch wear problems. And I too have read posts regaurding s4itty factory clutchs. Hoping mines here in a few weeks.
 

·
Registered
Joined
·
48 Posts
Discussion Starter #17
mines an 05 with 98k on it. I havent figured out whats the deal yet, I'm guess I'm going to have to take it in and get it looked at.
 
1 - 17 of 17 Posts
Top