Nissan Frontier Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
347 Posts
Discussion Starter · #1 ·
Anyone gad their cabin fan just stop working? Went to turn it on the other day and it no longer works on setting "1". 2, 3 and 4 work fine.

I've checked all the connections and the switch, but I cant figure it out.
 

·
Registered
Joined
·
5,563 Posts
Like Zebra says would be the first thing to check
have you got power going to the fan?
 

·
Rogue Admin
2007 LE 4x4 Crew Cab Long Box
Joined
·
15,482 Posts
i just went through this with my heater. if it works on 2 but not on others, its the resistor (so i was told by Nissan) - or 4 may work with AC. if it comes on briefly then shuts off, its the motor. mine blew both.

it must be a common problem because the dealer had the parts on hand and they had it fixed in under an hour.
 

·
Registered
Joined
·
5,563 Posts
so the motor was stuffed ?
 

·
Registered
Joined
·
5,563 Posts
well hope its not going to be an ongoing issue
did you find out what caused the issue like crap in the fan?
 

·
Rogue Admin
2007 LE 4x4 Crew Cab Long Box
Joined
·
15,482 Posts
well hope its not going to be an ongoing issue
did you find out what caused the issue like crap in the fan?
i think it happened going through deep water
 

·
Registered
Joined
·
5,563 Posts
sheesh dont use so much water when ya wash it lol
 

·
Registered
Joined
·
7 Posts
Can I bring an old thread back to life here?
I've got a similar problem - Hot or cold, fan only works on 4. 1,2 and 3 give me nothing. This is on a 98/4cyl frontier. Same cause as mentioned before? Any help is appreciated.

I think I just posted this in the wrong area. Blasted search function.
 

·
Registered
Joined
·
121 Posts
Hi All

Have any of you guys here in Aus had to replace the part after warranty has expired? Nissan Aus quoted $258 for the part, so I am wondering if anyone here has replaced it with a part ordered in from a US dealer

Cheers
Kyle
 

·
Registered
Joined
·
1,258 Posts
Hi All

Have any of you guys here in Aus had to replace the part after warranty has expired? Nissan Aus quoted $258 for the part, so I am wondering if anyone here has replaced it with a part ordered in from a US dealer

Cheers
Kyle
There has to be a cheaper aftermarket option that will work with the factory system. There are way to many companies in the A/C business for there to not be something else.
 

·
Registered
Joined
·
7 Posts
If its just the resistor, $258 seems way high. I got mine from the dealer here in Ontario for under $60. Problem is fixed now. Changing out the part was easy thanks to the info found on this forum.
 

·
Registered
Joined
·
121 Posts
Thanks Guys, Nissan Aus are thieves when it comes to these sorts of parts. I can get the Frontier part in from the states for about $60

Just wondering if one of the D40 Frontier owners out there could check and let me know if their fan resistor looks similar to the picture below ? If so, I'll get one sent over

Cheers
Kyle
 

Attachments

1 - 16 of 16 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top