Nissan Frontier Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter #1
I took delivery of my new 2016 Frontier Pro4x from the dealer just a few days ago. Awesome vehicle btw, I look forward to learning more about this truck on here. I do have a problem though, noticed today that the sunroof doesn't work at all. I push the button labelled UP/CLOSE and DOWN/OPEN by the map lights and nothing happens, no noise or movement at all completely dead. Unless I'm missing something here, I checked out the manual and it doesn't seem like there's any trick to doing this. Yes the truck was started the entire time I was pushing the button. It seems like all of my power windows/mirrors work fine though. Did somebody at the factory forget to connect some wiring? Maybe it's a motor issue? I immediately thought maybe it was a fuse. I opened up the 2 fuse boxes under the hood and the 1 by the glovebox. None of them seem to have a fuse location for the sunroof from what I can tell. If it's something simple I would rather just fix it myself then calling the dealers service dept. Any ideas?
 

·
Super Moderator
Joined
·
10,434 Posts
Let the dealer service this as you never want it to get stuck open either. Good luck and hope you enjoy the truck.

Clint
 

·
Registered
Joined
·
2,102 Posts
Is that something that would be disabled if the vehicle was still in "Storage/Transit Mode"?
 

·
Registered
Joined
·
10 Posts
Discussion Starter #4
I wonder if that's the case? Like VW's with that vag com tool you can use to tweak vehicle parameters. If not, then this bypassed QA at the factory. It also wasn't caught by the dealer during their so called PDI process? I could honestly care less about a sunroof but since the option is there, I want it to work properly. Unless it's something relatively simple I'll end up booking an appointment. It's just annoying that I have to bring it in for something that should have been caught beforehand. I hope I can trust these guys to fix the issue without creating any other ones.
 

·
Rogue Admin
2007 LE 4x4 Crew Cab Long Box
Joined
·
13,358 Posts
Sounds like you do need a trip to the dealer if there is no power and it isn't an easy fuse issue.

Send this to yourself for future reference, I have needed it in the past:

RE-TEACHING PROCEDURE
1. Using the UP/CLOSE switch, move the sunroof toward the tilt position until it stops.
2. Release the UP/CLOSE switch.
3. Press the UP/CLOSE switch again and continuously hold. The sunroof will begin to move in about 10 seconds.
4. Continue to hold the UP/CLOSE switch while the sunroof moves in a jogging motion to the full tilt position.
When the sunroof reaches the full tilt position, it will back up a few millimeters and stop.
5. Release the UP/CLOSE switch.
6. Within 5 seconds of releasing the UP/CLOSE switch, press and hold the UP/CLOSE switch again. The
sunroof will move to the full open position and back to the closed position.
NOTE:
If the UP/CLOSE switch is released anytime during this teaching process, all learned profile data will be discarded
and the procedure will have to be started over.
7. Release the UP/CLOSE switch. Do not disconnect power for at least two seconds. The sunroof is now retaught.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #6
UPDATE: I dropped off the truck at the dealer this morning and just got a call that the issue has been resolved. According to the service adviser, turns out the connection to the sunroof motor was loose from the factory. It must have been missed in QA. The dealer tech reseated the plug tight and the entire assembly works fine now. I'm relieved it was such an easy fix! I really enjoy driving this truck much more than the 2nd gen Tacoma I used to own. They gave me a brand new Sentra loaner which seemed like a decent compact sedan as well. I've heard horror stories about CVT transmissions but this one felt quite smooth and acceleration was brisk. I'm new to Nissan vehicles, owned mostly Toyota / Honda in the past and thus far I've been impressed. Thanks to all for the tips and suggestions.
 

·
Registered
Joined
·
27 Posts
I had an issue with my sunroof as well. Mine worked, but it would not seal when slid forward. I would have to pop it up, then back down for it to seal. Dealer said every nut was loose. Stated it may have been broken in transport and was replaced, but failed to be tightened properly.
 
1 - 7 of 7 Posts
Top