Nissan Frontier Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I'd heard all sorts of great things about the Frontier, so I bought a 2003 used crew cab which I though was in great shape.
It's giving me grief though. O2 sensor is what the code says. P0051
Anyone familiar with this code? I replaced all four sensors with aftermarket Bosch and I still get the code of P0051 though I've cleared it several times.
Suggestions anyone?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #3
First off I want to thank you for a reply.
No, the SES light was not on. I put about 2K miles on it when suddenly the light came on. I got the code and the full code reads as: P0051 Generic H02s Heater Control Circuit Low (Bank 2, Sensor 1)

After researching I found the Bank 2 Sensor 1 was the front left o2 sensor, upstream drive side. I have replaced it 3 times with "guaranteed" to work sensors. Just replaced it again two days ago with Bosch sensor and still get same code.

What I have done in the meantime is: new oem gas cap...new air filter and cabin filter...new rotor...new cap...all new plug wires...new plugs...checked MAF electrical...cleaned MAF with special cleaner...new fuel filter...checked all fuses for blown fuse...fresh gasoline as of yesterday and added some fuel injector cleaner just for good measure...

Still have same code. Since I am not very good at electrical troubleshooting, I am at a loss! Hmmmm...wonder how much more hair I can pull out!!!???
 

·
Registered
Joined
·
3,049 Posts
Since you've replaced the sensors multiple times to no avail, it is possible that this is a wiring issue??? Check the connection from the sensor in question. Look for any abnormalities, like damaged insulation or corrosion, etc. Keep us informed. Report back when you get this issue resolved.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I physically checked all the wires that I could get to. Nothing frayed, broken or melted. After messing with it in what seems like...forever...I got with a guy that does electrical troubleshooting for a living.
Using his, what I call, a 'super scanner' he finally, after 3 hours of searching and testing, found it to be a bad PCM.
Now that that is found out, I need to try and research and find where in the world it is located so I can get it out and have it replaced.

Anyone know where a PCM (not to be mixed up with ECM) is located on a 2003 Nissan Frontier SE?

What a great forum!!! Thanks guys, for all the fantastic suggestions!!!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Anyone know where the pcm (ecm) is located on a 2003 Frontier? I've been told it is in engine dept. close to fuses and others say it is under RH side behind glove box.
Anyone know for sure?
 
1 - 6 of 6 Posts
Top