Nissan Frontier Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
10 Posts
Discussion Starter · #1 ·
So i recently decided to add a little more ponies to the fronty did some research and found the Brute Force to be the one for its price and history. Installation came and went and after test driving the truck around some canyons and straights its seems to me that it has less power and its less responsive i mean it struggles to pass cars on the freeway any suggestions as to what may be wrong?:(
 

·
Registered
Joined
·
8,529 Posts
LOL, its an open box intake on a truck. Open box intakes tend to lower your TQ numbers and this is why your heavy azz truck feels sluggish.

The best thing you can do at this point besides selling the intake for a closed box design is to do the accelerator pedal reset, TB reset and an ECU reset and see if that helps.

How to:ECU Reset,Throttle & Accelerator Position Learning - Nissan Titan Forum
 

·
Registered
Joined
·
27 Posts
So i recently decided to add a little more ponies to the fronty did some research and found the Brute Force to be the one for its price and history. Installation came and went and after test driving the truck around some canyons and straights its seems to me that it has less power and its less responsive i mean it struggles to pass cars on the freeway any suggestions as to what may be wrong?:(
Sounds like something isn't right in the install?

When I plugged in my AFE Stage 2, there was a noticable drop in torque in the bottom of the rev range, but after 3k rpm it felt like it was a lot more than stock.

After a while, I missed the low down torque and had made up my mind to change out my AFE Open Box to a Volant/Injen cos of the loss of Torque lower down the rev range.

Instead, I plugged in my superchips, loaded the 93 Oct tune, removed WOT and added 2 deg timing advance. All in the matter of minutes. RESULT : Instant return of low end grunt, and it revs nice n free. :)
 

·
Registered
Joined
·
88 Posts
Hmm, I have the same intake as you. I did lose low-end power but I did gain at the higher RPM's. I have a Cortex on the way so I will be programming for additional HP/torque. If I were you I would do as others have said and try resetting the ECU.
 
1 - 4 of 4 Posts
Top