Nissan Frontier Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
187 Posts
Discussion Starter · #1 ·
Now this is my first tonneau cover and my buddy here has one on his truck. I love the look of it but I noticed that when I get to 60 MPH or so it starts to vibrate the vinyl really bad and I can hear the annoying sound in the cab. Now is this common cause my buddy's cover is the same one except on a Dodge Ram and his does not do this. Could this be cause by the mounting rails being set too high and air getting under the cover and causing more vibrations? Or should I loosen the cover even more than I already have? It is at the recommended tension from the manufacturer. Hopefully someone knows how to fix this problem. :cry:
 

·
Registered
Joined
·
3,458 Posts
Re: Access LiteRider cover - It rattles or vibrates bad - HE

Pele said:
Now this is my first tonneau cover and my buddy here has one on his truck. I love the look of it but I noticed that when I get to 60 MPH or so it starts to vibrate the vinyl really bad and I can hear the annoying sound in the cab. Now is this common cause my buddy's cover is the same one except on a Dodge Ram and his does not do this. Could this be cause by the mounting rails being set too high and air getting under the cover and causing more vibrations? Or should I loosen the cover even more than I already have? It is at the recommended tension from the manufacturer. Hopefully someone knows how to fix this problem. :cry:
i installed these covers daily at my previous job. no so much the lightrider, but the access and the lorado covers. they are all made by the same company. the access is the new version of the lightrider, and the lorado is the low profile version of the access......anways... on all the covers in installed, including my own, i always made the fairly tight. when you close it in the back, it should be a little tough to "snap" down into place. i keep mine tight like a drum. the only time i ever have to adjust the tension is durring drastic temp changes because the material it is made out of stretches and contracts so much. if this is not the prob, post some pics of your install job. i should be able to tell if you installed it wrong. good luck!
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #3 ·
sounds like a plan...yah mine is about that tight...just kind of annoying hearing the sound....doesnt seem as bad today though.
 

·
Registered
Joined
·
3,458 Posts
wow....even got a video lol. it seems to be installed correctly mine may be a little tighter than yours. but yours doesnt seem that loose. one other thing i do when i velco the sides down is pull from side to side too. then it pulls all the tension out. there are a few other things that would possibly be making noise. one is the plastic clips on the front to hold it when you have it rolled up. they could be hitting something and making noise. the other thing are the cross bars. do you have those installed? the only reason i ask is because they are removeable, and if you baught the cover used, the previous owner may have had them out for some reason. if you got it new, the come installed. the last thing would be on the very front of the cover there is a little vinyl flap. try tucking that down inside the box of the truck. i think the directions MIGHT say to install it with that flap on the outside, but i always do it on the inside. mainly because i think it looks like crap when it is out. other than that, i have no clue what it would be.
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #6 ·
yeah i took it off and reinstalled it a little closer to the box in the front. It has cut down on the rattle a lot. Yah i try and make sure i gave you as best look at the install as possible with the camera.
 

·
Registered
Joined
·
187 Posts
Discussion Starter · #7 ·
IT IS FIXED AND I LOVE IT!
 
1 - 8 of 8 Posts
Top