Nissan Frontier Forum banner
1 - 20 of 22 Posts

· Registered
Joined
·
175 Posts
Discussion Starter · #1 ·
Okay, maybe this should go on the end of my alternator post but thought I would try it here first. Just took the truck out for a quick spin after installoing a remanufactured Alternator and cleaning the battery terminal connections. RUns like a banshee, better then it has in some time (maybe just in my head but it sure felt like it), anyway, turning down my street I noticed that the ABS and SLIP lights were lit up, pulled int he driveway, shut her off, restarted and they lit up again. At least they are not the Devil Red colored ones I have been seeeing the last three months or so on and off (BRAKE and the little battery light), they a re a calming Yellow.

Any Ideas??
 

· Premium Member
Joined
·
174 Posts
when you disconnected the battery you lose the steering wheel angle sensor calibration. Try doing the reset according to the manual, if that doesnt work have to go to the dealership to get er recalibrated. Happened to me already stupid!!! good luck
 

· Registered
Joined
·
2,056 Posts
Probably broke or knocked loose the r/f abs wire when you were working on the alternator
 

· Registered
Joined
·
175 Posts
Discussion Starter · #11 ·
According to the owners manual all I have to do it drive in a straight line over 10 miles per hour for ten minutes...no wonder...my commute has been only two miles (due to weather) and I have not had her out on the highway since they came on. Come to think of it, they both came on before and went out, must have been going more then 10 for ten minutes, then I disconnected the battery for some reason and it came back on and I have not done the re-set procedure since that time. Guess I'll go for a drive and let you all know what happens.
 

· Premium Member
Joined
·
238 Posts
This happened to me 3 x's when I first bought my 2008, they did the reset and replaced the steering angle sensor twice, thankfully nothing has happened in over a year, but if you can't fix it with the reset take it to the dealer and get it fixed for sure.
 

· Registered
Joined
·
175 Posts
Discussion Starter · #14 ·
So, what would happen if I did not get the 'Steering Angle Sensor' replaced, if that is even what is wrong with it? It drives fine just is bothersome to see the lights on (still have not driven for ten miles over 10 miles/hour...).

Just curious, would the wheels fall off? or maybe I would get yanked into a ditch unexpectedly?

Scud
 

· Premium Member
Joined
·
238 Posts
According to the dealer when I took mine in the 2nd time and they had to order the sensor (or so they told me) they told me it would be fine and I could keep driving it, just that the traction control wouldn't work.
 

· Registered
Joined
·
175 Posts
Discussion Starter · #16 ·
Okay, the lights are still on after I tried the reset. I will contact the dealer / shop....hate doing that.... anyway, when I turn now I hear a harsh sound, sorta like something is rubbing even though there is not anything rubbing, happens while either turning right or left and it starts as soon as I begin a turn and continues until I get the wheels straight, then it goes away.

So how much is the stealership going to soak me for a 'steering angle sensor'., and is there an after market replacement that I can get from say, NAPA, or another auto parts store that I can do it???? Where is this sensor located on my car??

Thanks,

Scud
 

· Premium Member
Joined
·
238 Posts
So what ever happened? Did it fix itself or did you go to the dealer?
 

· Registered
Joined
·
175 Posts
Discussion Starter · #18 ·
I am going to the take it to the dealer shop and have them read the codes on Monday. The check engine light is not on so not sure which 'codes' they are talking about. I will let you all know Monday PM. BTW the lights are still on and no matter how I try it I can not get it to go into four-wheel drive, car off then switch to four hi does not work, at least on my truck.
 

· Registered
Joined
·
175 Posts
Discussion Starter · #19 ·
Okay, the shop read the codes and they it came up with a P1808 'FR RH Wheel Speed Sensor is shorted'..Cost for one of those is $150.00 according to them. They also said that if that did not fix the problem it may be my ABS actuator which is $1500.00. They will not know if that is it until they put in the $150.00 part and clear the codes. I did get her into four-wheel drive by pulling the ABS fuse, that is a trick I like.

The part will be in next Wednesday. I'll keep you posted.
 

· Registered
Joined
·
220 Posts
mine is going in for same thing on monday...it starts out difflock/vdc off light, then changes to abs/slip/vdc off light after a turn. Never know when its gonna come on, but seeing my diff locked at 60mph cant be good. I changed fluid in diff, it was brown.
 
1 - 20 of 22 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top