Nissan Frontier Forum banner

1 - 13 of 13 Posts

·
Rogue Admin
Joined
·
13,221 Posts
Discussion Starter #1
I've searched to no avail. My reverse lights are now staying on all the time and thought a quick search and I can probably fix this tomorrow. However, I cannot find anything on this issue for the Frontier, just thread after thread of LED lights.

I'm going to pull the fuse tomorrow to turn the damn things off, but was hoping someone may have come across this in the past and would be willing to point me in the right direction to properly repair this issue.

Is this a reverse switch on the tranny issue? Relay? Neutral switch? @smj999smj
 

·
Registered
Joined
·
105 Posts
IPDM I believe. Will look back through the manual to make sure.

Edit: Not exactly what I was remembering had tail lights and reverse lights mixed up for the fail safe function.
 

·
Rogue Admin
Joined
·
13,221 Posts
Discussion Starter #3
^ yeah, I have a feeling this will be a mechanical issue of some sort - relay, switch or something. Thanks for pulling that up about the tail lights, though. It may be something down the road.
 

·
Rogue Admin
Joined
·
13,221 Posts
Discussion Starter #4
Did some poking around and I tell ya, there are not many reference vids to help. I"m going to try the rear lights relay, will see what happens
 

·
Registered
Joined
·
2,961 Posts
I would check the reverse switch, typically on the transmission itself. These are simple contact/continuity switches.
 
  • Like
Reactions: Zedbra

·
Rogue Admin
Joined
·
13,221 Posts
Discussion Starter #6
No the transmission switch, the reverse lights have ironed themselves out, but now I am missing tail lights (the brake light works). I have checked all fuses and relays, they all seem fine. I'm a little stumped on this one, but I must admit, electrical is not my strong suit to diagnose.
 

·
Rogue Admin
Joined
·
13,221 Posts
Discussion Starter #7
Had a brief look into this today, reverse lights are back, no tails again. Going to need a morning to figure this one out, I didn't have the time today
 

·
Registered
Joined
·
105 Posts
What year is your truck again? I'm still leaning towards the IPDM or one of the relays on it.
 

·
Rogue Admin
Joined
·
13,221 Posts
Discussion Starter #11
Okay, I finally got the beast up on the hoist. Started looking at the wiring from the tail and worked my way back, checking continuity along the way. Got to the main harness disconnect located on the frame just behind the front passenger tire and sure enough, I had bashed the wiring harness while 4x4ing last hunting trip, and the exposed wires were intermittently shorting. I repaired 6 wires, then because I have a body lift, I routed the rear harness over the top of the frame, rather than leaving it to wrap down the frame where it can get hit again.

318345

318346
 

·
Rogue Admin
Joined
·
13,221 Posts
Discussion Starter #13
Was it one of those wires? fixed?
It was 6 of those wires that were cut through the sheathing, causing intermittent shorts. All fixed now, soldered, shrink wrapped, taped, and relocated the harness to prevent it happening again.
 
1 - 13 of 13 Posts
Top