Nissan Frontier Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I just brought a lease return 2017 4X4. Only 35k on it. When I bought it the end of June we were in a heatwave so I had the windows closed and the air on but one day in early August it cooled down and I had the windows open and heard a squeak from the front right suspension. I called Nissan. They asked I put white grease on where the hood gromets meet the body so I did and still the same sound. Called back a couple weeks later and made an appt. They said no charge. I went there and they wanted $135.00 to look at it but it rained the night before and the sound went away so I left as they said if they didn't find anything I would still have to pay. Anyone have any idea where this sound would be coming from. Its strange that it goes away when it rains but comes back the following day when its dry out. I did spray silicone spray on the bushing but the sound is still there. Any ideas would be greatly appreciated!
 

·
Registered
Joined
·
145 Posts
I also have a squeak, I thought mine was from the rear suspension/tailgate area. When its warm outside its quiet, when cool......squeak squeak.
I'm going to start my investigation by spraying the tailgate hinges/catches and go from there. Even if I don't find it, it's the folks outside the truck that have to suffer!
 

·
Registered
Joined
·
2,573 Posts
I also have a squeak, I thought mine was from the rear suspension/tailgate area. When its warm outside its quiet, when cool......squeak squeak.
I'm going to start my investigation by spraying the tailgate hinges/catches and go from there. Even if I don't find it, it's the folks outside the truck that have to suffer!
Also check and see if your spare tire is loose. Go underneath and try to move it.
 

·
Registered
Joined
·
145 Posts
Thanks Invasion08- such a simple possible solution, I overlooked it. I'll check it one day this week ( I was too lazy today)
 

·
Registered
Joined
·
68 Posts
Wrap some electrical tape around the hood latch pin. The rubber hood pads you mentioned. Sway bar to frame bushings were real greasy when mine was newer. Ive got good squeak going, so I removed them and greased them up again. No help! I'm at a loss right now. I wish you luck!

Sent from my SM-G970U using Tapatalk
 

·
Registered
Joined
·
2,573 Posts
Thanks Invasion08- such a simple possible solution, I overlooked it. I'll check it one day this week ( I was too lazy today)
Any update?
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
(Solved) I think, I found a loose front right body mount. I tightened it up and the squeak seems to have gone away.Question is why is the body mount loose?? Truck is a certified pre-owned 2017 no accidents per Car Fax.
 

·
Registered
Joined
·
68 Posts
I have a 2014. Was told my truck was a lease return. With possibly the same squeak. It can take up to a year for Carfax to be updated. If insurance didn't pay out a claim, the repairs don't always get reported. A year after my purchase, I had already my vehicle was repaired due to damage, maybe an accident. And its a rental return! Mostly my fault, I bought from a local large scale dealer who back in the 1990s was right in the middle of buying damaged out of state vehicles, repairing and selling as a clean history car. Once shady as [email protected], always shady as [email protected]!! Anyway, my right front mount is tight, but looks suspicious. So its coming apart for a better look!

Sent from my SM-G970U using Tapatalk
 
1 - 8 of 8 Posts
Top