Nissan Frontier Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
80 Posts
Discussion Starter · #1 ·
I have a new (2700 miles on it currently) 2016 Frontier. The last few mornings when I have started it up there is a slight squeak from the front of the engine area.
Sounds like a belt and acts like a belt....noise goes away within a few minutes of warming up.

Wondering if this is a know thing or if my rig is "special".

I plan on videoing the noise and taking it to dealership as it only does it for the first start of the day and I doubt they will be able to recreate the noise.
 

·
Super Moderator
Joined
·
11,258 Posts
Take it in, might be a belt or tensioner.

Clint
 

·
Registered
Joined
·
11 Posts
I've got a 2016 with 19k on it and noticed the same thing this morning. I'm going to take it in and get it looked at, I assume it's belt related.
 

·
Registered
Joined
·
80 Posts
Discussion Starter · #5 ·
Problem with taking vehicles to the dealer with intermittent issues is getting it to do it while it is there. This morning I had my iPad all fired up and recording when I started the truck....and nothing. Did not squeak today.

So that is why I posted up here. Thinking maybe someone else has the same issue and I can help focus the dealership to the problem.

With less then 3000 miles on the truck and am not to happy to already be having issues.

I owned a 2009 Xterra that was junk. One thing after another. Sold it before the warranty ran out. Hoping the Frontier does not turn into the same problem vehicle.
 
1 - 5 of 5 Posts
Top