Nissan Frontier Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hey everyone, new to the forum hence why I’m posting here. I own a 2014 Nissan Frontier pro-4x with around 70k miles that has never let me down... however, it has recently started to take a little more time to start, has a slight leak when it’s running that goes away a little after it’s stopped (A/C?) and I can feel the car shake when I’m stopped and at idling speeds. Shifting into neutral helps the shaking very slightly and I’m thinking I might need new sparkplugs but it’s just a guess. Any help is greatly appreciated, thanks!
 

·
Registered
Joined
·
14 Posts
Hello M, sounds like you may have several possible things to check for, so lets start at the top, has it been serviced lately?, has someone been under the hood for something...washer fluid, brake fluid and maybe accidently bumped a sensor loose, vacuum hose loose or fallen off? to check this get a can of ether or starting fluid and give it a small shot at different spots around the engine...WARNING..ether or starting fluid is very explosive so I suggest to not spray around the exhaust manifolds, but if you have a vacuum leak it will increase the engine speed if sprayed close to a leak. #2 put a half bottle of 91% isopropyl alcohol to a half a tank of gas to disperse possible water in you gas, yes I mean rubbing alcohol. Let me know your results. (y)
 

·
Registered
Joined
·
908 Posts
First things first.. how long have you had this..bought it new? Did you just start noticing the leak? Are you running the air conditioner when you notice it leaking an is the leak at or around the passenger side floorboard underneath?
Also many of us have the rough idle at times, I’m not sure what causes it exactly but all three of mine has done it, just thought it was a Nissan thing.

Unless you’re familiar with how things work under the hood of an automobile I would not suggest spraying anything combustible under there.
 

·
Registered
Joined
·
1,660 Posts
My guess is a battery that is starting to fail and the leak is condensation from the exhaust. Has the temperature recently gotten colder?
 

·
Registered
Joined
·
3 Posts
Discussion Starter #6
First things first.. how long have you had this..bought it new? Did you just start noticing the leak? Are you running the air conditioner when you notice it leaking an is the leak at or around the passenger side floorboard underneath?
Also many of us have the rough idle at times, I’m not sure what causes it exactly but all three of mine has done it, just thought it was a Nissan thing.

Unless you’re familiar with how things work under the hood of an automobile I would not suggest spraying anything combustible under there.
The leak is by the passenger side wheel. Bought the truck used but these problems only started showing up recently and not when I first got it. But I’m going to see if it still leaks with the AC off
 

·
Registered
Joined
·
908 Posts
I’m not sure about the slow starting.. possibly battery?? Not sure if you mean cranking slow or just cranking longer before starting. I would not think the plugs would need changing yet either. These trucks do have a lot of condensation when first started.. mine leave quite a bit on the ground where it was sitting when warming up.. cold or hot out. Comes from muffler and tail pipe. But if it’s up behind the front passenger wheel it’s more than likely AC.
 
1 - 7 of 7 Posts
Top