Nissan Frontier Forum banner
1 - 5 of 5 Posts

· Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Thought I would move this to the general section......relates to a P1126 code 2001 Frontier 2.4
Ok, I have replaced the thermostat (twice), the pressure cap, water pump, and the engine temperature sensor. After all of this I still have the code, one OBD2 check showed a throttle position sensor (some searches show this engine doesn't have, but it does) and yet the code is still pointing to the thermostat - the engine starts, runs fine, and heats up as normal (the only thing I have noticed a couple of times is a brief 'bucking' when accelerating.......
 

· Registered
Joined
·
25 Posts
I'll echo/second boom10ful here.
A bad ECU coolant temp sensor will cause bucking/strange running problems, as the ecu pulls timing and adds tons of fuel when that sensor goes bad, or measures an overheat situation (such as a trapped air pocket at the sensor).
Also, it is very common for parts store/rockauto thermostats to be crap. Spend the extra couple bucks and get a genuine Nissan thermostat, and make sure it is installed in the proper orientation, with the bleeder valve up. Make sure to take your time and bleed the coolant system as well, with the front end jacked up as high as you can get it.
EDIT: Be sure to check the wiring harness at the sensor as well. Old cracked/frayed wiring has been the culprit of more than one headache of mine.
 

· Registered
Joined
·
879 Posts
Not sure if this is related...but have you seen this YouTube video...re: thermostatic fast idle solenoid....
 
1 - 5 of 5 Posts
Top