Nissan Frontier Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hello I am new to this forum and have no idea where to post this issue I am in desperate need of advice I have a 2000 Frontier se crew cab 4x4 automatic with the 3.3l the issue is when I take off no matter how hard or easy I take off from a stop I have a bad vibration till it gets to about 3rd gear or so and even then it still will vibrate the whole truck. I have so far replaced the engine mounts transmission mount all ujoints center carrier bearing rear end I have flushed the transmission and transfer case and pried on everything I could get ahold of. Nothing feels loose I work at a Chrysler and ford dealership and have put it up on my lift and can’t get the vibration to happen at all I have tried 2wd 4hi and 4lo. Also it seems sometimes when it goes into its lockup in overdrive somewhere around 45 it will slam in any ideas would be greatly appreciated
 

·
Super Moderator
Joined
·
3,839 Posts
Sounds like it may be an internal transmission issue by your description...possibly a bad torque converter?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
I changed the filter and fluid and put in a bottle of shudder gaurd not even a slight difference in driving I was kind of leaning towards Tranny issue but when I’m driving it and it’s vibrating the truck it doesn’t feel like the rumble strip theory. Also it happens on takeoff could torque converter shutter happen on takeoff and at all times
 
1 - 4 of 4 Posts
Top