Nissan Frontier Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
My frontier has 352k miles on it. I have always self serviced this truck. Other than routine maintenance, I really haven't had to do much, I've always been able to find the issue and correct it....till now! I need some help. The problem is not to anything I've recently done as it was there before. Will idling it sounds fine and run a fine, no skipping, jumping etc. Then it just dies. While driving today, it cut off on me, I left in gear in hopes that it would pick back up, but did not. Once on the side of the road, it crunk right back up and later does it again, only this time it recrunk itself before it stopped while in gear? Since these issues have started, I have given it a complete tune up, like I said it runs great then bam it's dead. No codes at all. Any ideas?
 

·
Registered
Joined
·
209 Posts
welcome to the forum BigJoe. Sudden loss of power and no codes makes me suspect battery and ground connections. Just a good place to start. My 2000 cherokee had those symptoms, and it turned out to be a crankshaft position sensor. Never got a CEL.
 

·
Registered
Joined
·
3,199 Posts
Wow, 352K miles is a lot. I've got 222K on my '98 Frontier which I bought for my kids to drive in 2004, with 100K on it, and it was later returned to me in 2013 (after I bought a 2004 Frontier in 2011 of course).

I had to replace the electrical part of the ignition switch in mine so don't forget to check that out. The circuits for cranking the engine and starting are separate. That was an easy R&R, I just took off the lower steering cover, did not have to remove the steering wheel or disable air bag.
 
1 - 3 of 3 Posts
Top