Nissan Frontier Forum banner

1 - 4 of 4 Posts

·
Registered
2006 frontier xe 2.5l A/T
Joined
·
3 Posts
Discussion Starter #1
I have the 06 xe and when I bought it , it will shift up until about 60 and if I had to stop quickly it will just stay in 4th gear from a stop until I get up to speed, lately I’ve just been turning it off and back on which has been working, sometimes it’ll continue to shift others times it won’t grandma slow pulling from a light, now that I got that out, will a new tcm fix this problem. I prefer to get one out of a running or wrecked truck that works fine, a new one and taking it to Nissan is the last option.
 

·
Registered
Joined
·
822 Posts
Check for water(coolant) contamination in your transmission fluid. It will look cloudy-milky if its been contaminated.That means your tranny is ruined.
 

·
Registered
2006 frontier xe 2.5l A/T
Joined
·
3 Posts
Discussion Starter #4
No it’s still normal tranny red, I took a valve body out of a titan with the same trans, clean tranny fluid. So it should work
Check for water(coolant) contamination in your transmission fluid. It will look cloudy-milky if its been contaminated.That means your tranny is ruined.
tranny fluid was still red, I put a valve body and tcm from a titan and it’s running and shifting normal again, but sometimes will feel like it bogs until you floor it then it’ll accelerate. Idk what it’s from but there’s no check engine light, it doesn’t happen if I drive aggressively though.
 
1 - 4 of 4 Posts
Top