Nissan Frontier Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Long time reader, first time poster. Most any question i've ever had is usually answered within 15 minutes of browsing threads, except now. I replaced my plugs today and found that the #5 plug is soaked in oil. Pulled the valve cover off and found no apparent signs of damage to the plug well seal, but i've ordered a new cover to replace it and hopefully resolve the leak.

Has anyone encountered this situation? If so, what was your attack plan and did you encounter any complications? As always any experience / input is appreciated.
 

·
Registered
Joined
·
50 Posts
Had the same thing happen. Gaskets had gone at 109000
to be expected I guess
all told a few hundred parts and labor
 

·
Registered
Joined
·
1 Posts
same thing happened to me today

Long time reader, first time poster. Most any question i've ever had is usually answered within 15 minutes of browsing threads, except now. I replaced my plugs today and found that the #5 plug is soaked in oil. Pulled the valve cover off and found no apparent signs of damage to the plug well seal, but i've ordered a new cover to replace it and hopefully resolve the leak.

Has anyone encountered this situation? If so, what was your attack plan and did you encounter any complications? As always any experience / input is appreciated.
---just changed all six plugs and the driver side plug near the firewall had a little bit of oil on the thread. not sure what to do. ill do my research.--
 

·
Registered
Joined
·
4 Posts
Discussion Starter #5
I ended up buying a new valve cover since you cant service the o-rings for the plug tubes on the cover. $30-$35 if you do the work yourself. My buddy suggested i just rtv the ring and call it a day which i guess would work, but i just went for the new cover.
 

·
Premium Member
Joined
·
1,011 Posts
1 - 6 of 6 Posts
Top