Nissan Frontier Forum banner

05 Frontier Nismo cranks but won't start intermittently

12239 Views 27 Replies 9 Participants Last post by  smj999smj
Hi all,

It started few months ago with my 05 Frontier. Sometimes when I go to start the truck it will turn over but not fire but once it starts, it runs perfect. It happened again this morning, the car started up no problem the first thing in the morning and I drove it for about 10 miles then turn off the engine. Five minute later I tried to start the truck, it cranked but wouldn't start and I even tried the trick that turn the key to On position and wait for few seconds. I tried a couple times to no avail then I decided to let it sit for couple minutes and tried again and this time it just fired up like nothing happened. The battery is good and I replaced the fuel pump, both camshaft position sensors and crankshaft position sensor last year. I did quite a bit of research on this problem and it looks to me that it happens to different across all Nissan models and not limited to Frontier alone. But so far no concrete answer to the cause of the problem and how to fix it. Any suggestion would be greatly appreciated.

1 - 12 of 28 Posts
No code at all.
OK thanks. I didn't know that there are other codes store in there beside the check engine light error codes.
So if I bring it to the dealer that what should I tell them so they don't look at me and think 'What the heck is this guy talking about?'
130K miles. The spark plugs replaced around 80K.
When it refused to start, I pulled the coil, ground it with another plug and there was no spark. Of course after I waited for few minutes, it started right up just like nothing happened. Also, the crankshaft position sensor was replaced last week with the OEM part from the dealer. So do you think the ECU is its way out?
Hi KurtVH,

Can you tell me where can I find all the ground connections for the 05 frontier?

Yes, I have the FMS but I have no idea where to look.
Thanks. I'll check it tonight.
No I just have to live with it. One good thing that without fail, it would start after 10 minutes.
I might try to get a new key to see it will fix the problem. Anyway just like I've been saying, it seems like there is a timer somewhere in there that tell the computer not to send any spark until the 10 minutes are up.
Just got a new chipped key and it didn't fix the problem. The only thing left is the ECM and that thing is expensive.
1 - 12 of 28 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.