Airbag light wont reset after radio install - Nissan Frontier Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 08-20-2011, 05:37 PM
Shift_lurker
 
asnell910's Avatar
 
Join Date: Dec 2010
Posts: 16
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Airbag light wont reset after radio install

Hi guys. I installed a Pioneer AVH-P3300BT and disassembled the driver side dash to route the microphone up to the map light. After putting it back together, everything worked fine. The airbag light came on a few days later (anywhere from 3-6 days) when my mother took a road trip in my car. I do believe I kept the battery in for the install, but not 100% sure. It's been about a month since then. I've tried the reset procedure, and the light actually did reset, but came back on in about a minute after turning on the engine and driving. I tried disconnecting the battery as well, and everything reset (trip odometer back to 0) but the airbag light stayed on.
Also, not sure if this is related, but about 1-2 weeks ago, my TPMS indicator flashed for a minute then stayed illuminated (without flashing) for a few days. It has turned off since. All tires are 35-36 psi. Perhaps the hot Houston weather right now could have affected the system.
asnell910 is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 08-25-2011, 10:51 AM
Shift_Newbie
 
elvis164's Avatar
 
Join Date: Sep 2008
Posts: 63
Thanks: 1
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
I had the same problem, fix is in the second or third response of this post. Works like a charm.
elvis164 is offline  
#3 (permalink) Old 08-28-2011, 10:22 PM
Shift_lurker
 
asnell910's Avatar
 
Join Date: Dec 2010
Posts: 16
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
BUMP

To what post? If you are referring to the reset procedure, that does not fix the problem. The light does reset and stays off, but comes back on after starting the engine.

Come on guys, I don't want to support the stealership
asnell910 is offline  
#4 (permalink) Old 09-03-2011, 01:13 PM
Shift_Enthusiast
 
Join Date: Oct 2007
Location: BFE, AZ
Posts: 443
Thanks: 0
Thanked 102 Times in 76 Posts
Feedback Score: 0 reviews
If the light comes back on after resetting then there is something wrong. take it apart again, make sure you have everything hooked up right (this includes the passenger airbag off light) and try resetting again. If that does not do it, then you will need to have the codes pulled to figure what circuit the problem is in and fax accordingly.

You can't keep the light off if there is an active problem. Fix the problem and the light will stay off.
V8 man is offline  
#5 (permalink) Old 09-04-2011, 01:29 PM
Shift_lurker
 
asnell910's Avatar
 
Join Date: Dec 2010
Posts: 16
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by V8 man View Post
If the light comes back on after resetting then there is something wrong. take it apart again, make sure you have everything hooked up right (this includes the passenger airbag off light) and try resetting again. If that does not do it, then you will need to have the codes pulled to figure what circuit the problem is in and fax accordingly.

You can't keep the light off if there is an active problem. Fix the problem and the light will stay off.
Thanks for the advice. I have removed and reinstalled the center panel with the radio and AC controls and the light still comes on. Correct me if I am wrong, but when I do the reset procedure, the light either stays off or does one long blink and several short blinks indicating the fault codes. When I do the reset procedure, the light stays off and doesn't show any fault codes. The light will stay off when just the electronics are on and not the engine. Once I start the engine and pull our of my garage, the light comes back on. I will try disconnecting the entire driver's side dash and try again.

Would I have to go to the dealer to get the codes, or could I go to a 3rd party shop?
asnell910 is offline  
#6 (permalink) Old 09-04-2011, 03:53 PM
Shift_Obsessed
 
mdawg4x4's Avatar
 
Join Date: Sep 2006
Location: Madison, MS
Posts: 3,525
Thanks: 228
Thanked 384 Times in 294 Posts
Feedback Score: 0 reviews
Some parts places will read the codes for you.

06 NISMO CC 4X4: 2 1/2" lift w/285/75-16 BFG MT KM2s, Alpine CDA-9857 HU, Alpine Type R 6.5 components in front, Type R 6.5 3-way in rear, Flowmaster 40, NISMO CAI, NISMO radiator and oil fill caps, Bushwacker Flares, Calmini winch bumper w/Warn 9.5cti, KC SlimLites, and PIAA 510 fogs
98 Jeep Wrangler: 2" spacers, Rubicon coils, Borla Header/Flowmaster, 33-12.50 BFG MTs on 15X8 MT Classic Lock, KC 150W Daylighters, Pioneer HU and speakers w/RF 12" P3 sub and MTX amp
1963 Nissan Patrol L60 (project): 2013 Xterra PRO4X (wife's): 2012 Xterra SV 4X4 (daughter's)
mdawg4x4 is offline  
#7 (permalink) Old 09-05-2011, 12:17 PM
Shift_lurker
 
asnell910's Avatar
 
Join Date: Dec 2010
Posts: 16
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
I talked to a few car care shops and they all said to go to the dealer. I tried removing the whole driver's side dash and reconnected everything and reset the light after. As soon as I started the engine and pulled out of the garage, the light started blinking again.

If this is a problem that isn't fixed by resetting the light, then why wont the light flash the codes to me when I try resetting it? Is there anything else I should try before taking it to the dealer?

UPDATE 9/4/2011: I've been using this reset procedure:

I tried it again today, but only cycled the ignition switch 3 times and when turning the car on a fourth time, the airbag light kept flashing the longer than usual flashes. I believe this is a diagnostic mode, but it's not flashing a valid trouble code like the code shown in the video. There are no short flashes following the long flashes.

Last edited by asnell910; 09-05-2011 at 09:15 PM.
asnell910 is offline  
The Following User Says Thank You to asnell910 For This Useful Post:
alexd51 (02-16-2013)
#8 (permalink) Old 02-02-2013, 08:02 PM
Shift_lurker
 
Join Date: Sep 2012
Location: Utah
Posts: 11
Thanks: 3
Thanked 12 Times in 5 Posts
Feedback Score: 0 reviews
The reset procedure is below if you cant find it (like me)

The Process is :
If your Airbag Light is flashing on your Nissan it will not go off until it is reset. You can take it to your dealer, but most likely they will reset it (and probably charge you) and tell you if it comes back on there might be a problem and then they will do further diagnostics or replace the wiring harness (this is very expensive). For some reason this sensor trips quite frequently and we used this procedure a lot at the a Nissan Dealership I worked for. This works for most if not all Nissan models. Follow these directions-

1. Turn the key from off to on.

2. Watch the airbag light closely. It will stay on for a few secs. and then as soon as it blinks off (the start of the flashing), turn the key off instantly.

3. Count to 5 (1 Mississippi, 2 Mississippi . . . .) Don't rush this or it will not work.

4. Repeat steps 1-3 two more times until you have done the cycle three times.

5. Now turn the key on and watch the light. It will start blinking in a different, slower manner. This is diagnostic mode. You can watch this for a little while, no hurry.

6. Now turn the key off again, Count to 5 like in step 3 again, and turn back on. If the procedure worked, the airbag light will not be flashing.

If it does not work the first time, just repeat the steps again.
kprtx is offline  
The Following 7 Users Say Thank You to kprtx For This Useful Post:
alexd51 (02-16-2013), aR (04-24-2013), crewmaxxis (07-25-2013), d's toy (08-17-2014), Rogo43 (02-02-2013), stepside (04-30-2013), Steveh (02-20-2013)
#9 (permalink) Old 02-02-2013, 10:12 PM
Shift_Obsessed
 
Join Date: Sep 2006
Posts: 6,057
Thanks: 0
Thanked 830 Times in 582 Posts
Feedback Score: 0 reviews
Don't we drive Frontiers?
zoomzoom is offline  
#10 (permalink) Old 02-04-2013, 03:57 PM
Shift_lurker
 
Join Date: Sep 2012
Location: Utah
Posts: 11
Thanks: 3
Thanked 12 Times in 5 Posts
Feedback Score: 0 reviews
...Yes?

I'm not sure if I understand the question... It was a cut and paste. I apologize if it has something like titan, or maxima in it. It is for the frontier, and worked perfect on my 2005 NISMO.
kprtx is offline  
The Following User Says Thank You to kprtx For This Useful Post:
alexd51 (02-24-2013)
Reply

  Nissan Frontier Forum > Mods and Technical Discussions > Interior Mods

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Frontier Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On