Trailer turn signal wiring problem - Nissan Frontier Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 07-22-2007, 04:37 AM
Shift_Newbie
 
silvrsled's Avatar
 
Join Date: Mar 2006
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Trailer turn signal wiring problem

Well, I hooked up the trailer the other day and the left turn signal wasn't working. The one on the truck was working fine so I started to trace it down. Basically, went all the way to the 7 pin connector. No power out of it. Next I went under the truck and checked the connector on the frame. Found the wire for the left turn signal and there was no voltage coming out of it with the signal on. At this point, I'm stumped. I checked the fuse box but there were no turn signal fuses. Has anyone had this problem?
silvrsled is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 07-22-2007, 04:13 PM
Shift_Obsessed
 
Frontier2's Avatar
 
Join Date: Feb 2006
Location: Cantonment,FL
Posts: 2,940
Thanks: 0
Thanked 42 Times in 39 Posts
Feedback Score: 1 reviews
Check under your RF kick panel and make sure the tow harness/relays are there.There should be 2 blue,1 brown relays for man. 1 blue,1 brown for auto they should be wrapped up in foam.

06 MAJESTIC BLUE 4X2 LE KC
Frontier2 is offline  
#3 (permalink) Old 07-22-2007, 10:48 PM
Shift_Enthusiast
 
Join Date: Jun 2005
Location: Warrenton, VA
Posts: 182
Thanks: 0
Thanked 1 Time in 1 Post
Feedback Score: 0 reviews
Trailer wiring recall...

Take it to the dealership and they should replace it for free. I did and they did it.
SilverSE05 is offline  
#4 (permalink) Old 07-22-2007, 10:51 PM
Shift_Newbie
 
silvrsled's Avatar
 
Join Date: Mar 2006
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I put the tow harness in myself so I definitely know they are there. I do have an extra harness though that I can try out. Thanks!
silvrsled is offline  
#5 (permalink) Old 07-23-2007, 03:27 AM
Shift_Obsessed
 
dcobb's Avatar
 
Join Date: Oct 2006
Posts: 4,478
Thanks: 0
Thanked 5 Times in 5 Posts
Feedback Score: 0 reviews
I'm currently having the same problem, or similar one, my left break light / signal for the trailer wiring isn't working. Haven't traced the problem yet, but my break lights on the truck work just fine. Probably loose connection somewhere...
dcobb is offline  
#6 (permalink) Old 10-07-2007, 02:47 AM
Shift_Newbie
 
silvrsled's Avatar
 
Join Date: Mar 2006
Posts: 64
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Hey, i finally solved my problem. If you look under your driver side dash, is a dual fuse holder with 2 white caps. one of the fuses was burnt out. Replaced it and now it's fine. I'm guessing I must have blown it when I was probing the pins at the hitch connector. Probably shorted out the turnsignal since it's right next to the ground lug.
silvrsled is offline  
#7 (permalink) Old 10-07-2007, 11:04 AM
Shift_Enthusiast
 
hmontaq's Avatar
 
Join Date: Mar 2007
Location: Miami Florida
Posts: 158
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I have a similar problem. Uhaul installed it and has a warrenty. They couldnt figure it out so its the stealership for me soon. Glad you got yours figured out.

2005 CC NISMO auto Storm Grey/ NISMO CAI/ Hunter Bull Bar/ Debadged tailgate/ Demudflaped/ CST 4" Spindles w 2" Blocks/ 18x9 Moto Metals 285/60/18 Nitto Desert Tires/ Eclipse 3100 deck, Kicker 45x4 channel amp, 4x651 Polk Audio coax speakers/ Blacked out badgeless grill/ Custom NISMO Offroad fender logos/ Destickered Roof Rack

2006 Sinister DNA
2007 KTM 690 Supermoto
Deckcrafters Skateboards
hmontaq is offline  
#8 (permalink) Old 10-07-2007, 11:55 AM
Super Moderator
Shift_Obsessed
Lifetime Member
 
Zero Six LE's Avatar
 
Join Date: Aug 2006
Location: Miltown,Florida
Posts: 16,735
Thanks: 5,897
Thanked 1,547 Times in 1,156 Posts
Garage
Feedback Score: 0 reviews
Quote:
Originally Posted by hmontaq
I have a similar problem. Uhaul installed it and has a warrenty. They couldnt figure it out so its the stealership for me soon. Glad you got yours figured out.

Is Uhaul going to pay for the dealer's work?



Zero Six LE is offline  
Reply

  Nissan Frontier Forum > Nissan Frontier Forums > General Discussion

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Frontier Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On