Heater blowing cool air. - Nissan Frontier Forum
Reply
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 12-07-2009, 07:09 PM
Shift_lurker
 
Join Date: Aug 2006
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Heater blowing cool air.

Hi folks,

I just noticed that my heater is blowing cool air. It just started happening this week. The temp gage isn't too hot or cold it just blows cold air. I don't have any coolant leaks and have also noticed that if I rev the engine to about 4 RPM's it blows hot...just like the good ol' days. You think it's the thermostat or something else? It's a 2006 Nismo.

-Thanks,
-TJ
tjcolda is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 12-07-2009, 07:28 PM
Shift_Obsessed
Lifetime Member
 
Join Date: Dec 2007
Location: Northern New Jersey
Posts: 7,495
Thanks: 256
Thanked 762 Times in 589 Posts
Feedback Score: 0 reviews
I believe your thermostat is stuck open.

Clint

The government cannot give to anybody anything that the government does not first take from somebody else.


2010 Nissan Frontier SE Crew Cab Long Bed 4X4 Radiant Silver 6-Speed
2007 Nissan Pathfinder SE 4X4 Desert Stone
2011 Nissan Rogue SV AWD Frosted Steel
2012 Dodge Challenger SRT8 Yellow Jacket Edition 6-Speed Stinger Yellow
2014 Nissan Sentra SR Aspen White
Clint is offline  
#3 (permalink) Old 12-07-2009, 07:30 PM
Shift_Fanatic
 
chaz's Avatar
 
Join Date: Nov 2009
Location: massachusetts
Posts: 703
Thanks: 14
Thanked 22 Times in 20 Posts
Feedback Score: 0 reviews
mine does the same thing 06 cc,it takes a little while to get warm,mostly when things are really flowing like driving on the road,then it gets hot,just at idle not very warm.
chaz is offline  
#4 (permalink) Old 12-07-2009, 08:57 PM
Shift_Obsessed
 
Mathster's Avatar
 
Join Date: Nov 2009
Location: Oklahoma
Posts: 4,067
Thanks: 39
Thanked 372 Times in 319 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by tjcolda View Post
Hi folks,

I just noticed that my heater is blowing cool air. It just started happening this week. The temp gage isn't too hot or cold it just blows cold air. I don't have any coolant leaks and have also noticed that if I rev the engine to about 4 RPM's it blows hot...just like the good ol' days. You think it's the thermostat or something else? It's a 2006 Nismo.

-Thanks,
-TJ
check your coolant level in the radiator on a cool engine. I bet your low.
My 00 does that, but mine likes to puke sometime each night and after a month or so, it will get a little low.
The only time I have seen the temp rise above normal was letting my son drive around an industrial park to get some practice.

00KCDRXE
13CC4x4SV
Mathster is online now  
#5 (permalink) Old 12-07-2009, 09:03 PM
Shift_lurker
 
Join Date: Dec 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Yup, check your antifreeze. Bet it's low. Mine does the same thing, just started recently. I've been having to add about 1/2 gallon every two weeks or so. I have no idea where it's going. No leaks that I can see, and I'm pretty sure it's not burning it. Any ideas out there?
Vootie is offline  
#6 (permalink) Old 12-07-2009, 09:33 PM
Shift_Newbie
 
tperkins's Avatar
 
Join Date: Oct 2008
Location: georgia
Posts: 92
Thanks: 1
Thanked 4 Times in 3 Posts
Feedback Score: 1 reviews
hopefully not the transmission

2.5" extended radflos, Deaver AAL, PRG adjustable shackles, 2 inch BL, Bilstien 5150's, trail gear sliders, flowmaster 50 series, new y pipe, air box mod with k&n filter, BFG at ko 285/75r16's, Pro Comp wheels,leer r100
tperkins is offline  
#7 (permalink) Old 12-07-2009, 09:39 PM
Super Moderator
Shift_Obsessed
Lifetime Member
 
Zero Six LE's Avatar
 
Join Date: Aug 2006
Location: Miltown,Florida
Posts: 16,680
Thanks: 5,793
Thanked 1,519 Times in 1,135 Posts
Garage
Feedback Score: 0 reviews
Surely sounds like air in the cooling system.



Zero Six LE is offline  
#8 (permalink) Old 12-07-2009, 09:41 PM
Shift_lurker
 
Join Date: Dec 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine's a six speed, so I'm pretty sure that's not where it's going.
Vootie is offline  
#9 (permalink) Old 12-07-2009, 09:46 PM
Shift_Obsessed
 
Mathster's Avatar
 
Join Date: Nov 2009
Location: Oklahoma
Posts: 4,067
Thanks: 39
Thanked 372 Times in 319 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Vootie View Post
Yup, check your antifreeze. Bet it's low. Mine does the same thing, just started recently. I've been having to add about 1/2 gallon every two weeks or so. I have no idea where it's going. No leaks that I can see, and I'm pretty sure it's not burning it. Any ideas out there?
like I said, mine pukes. its not a consistent leak the truck doesn't leak at work, just at home and just overnight..

If you have a gen1. it could also be a head gasket leaking into one of the cylinders.

00KCDRXE
13CC4x4SV
Mathster is online now  
#10 (permalink) Old 12-07-2009, 09:52 PM
Shift_lurker
 
Join Date: Dec 2009
Posts: 15
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Mine's a gen 2, '06 Se. I've parked in my garage overnight a couple times to see if there was any spillage, but none to report. I do smell antifreeze occasionally after I shut the engine off in the front of the truck. My guess is it's leaking a bit near the header and burning off.
Vootie is offline  
Reply

  Nissan Frontier Forum > Nissan Frontier Forums > General Discussion

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Frontier Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On