FIX: Front Turn Signal Issues - Nissan Frontier Forum
 
LinkBack Thread Tools Display Modes
post #1 of 1 (permalink) Old 03-04-2011, 11:04 PM Thread Starter
Shift_Enthusiast
 
AngryMallard's Avatar
 
Join Date: Aug 2009
Location: West Palm Beach, FL
Posts: 106
Mentioned: 0 Post(s)
Quoted: 2 Post(s)
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Send a message via AIM to AngryMallard
FIX: Front Turn Signal Issues

I recently (for the past year and a half) have been having problems with my front turn signal not working at all despite having a good bulb and fuse (AND good ground connections AND everything else seeming to work properly). At least one other person has had this problem:

right turn signal help

After removing the housing (which was a PITA until I realized it was really simple to remove) and inspecting the wiring on the harness, it seemed that one of the wires on the inside of the housing had unattached from the bulb socket. The problem was not readily visible, but was fixed by soldering the wire to the side of the housing. I decided this solution was better than paying Nissan $121 for a new housing.

I have more detailed pictures and instructions here:

http://builtsomething.blogspot.com/2...e-one-bit.html

Hopefully this helps some people!

'99 XE-V6 KC 4x4
Also:
'72 VW Super Beetle
'06 Honda Shadow
'71 Yamaha 175

Last edited by AngryMallard; 03-04-2011 at 11:06 PM.
AngryMallard is offline  
Reply

  Nissan Frontier Forum > Nissan Frontier Forums > 1st Gen Hangout

Quick Reply
Message:
Options

Register Now



In order to be able to post messages on the Nissan Frontier Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.

User Name:
Password
Please enter a password for your user account. Note that passwords are case-sensitive.

Password:


Confirm Password:
Email Address
Please enter a valid email address for yourself.

Email Address:
OR

Log-in









Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On