1st Gen Hangout - Nissan Frontier Forum
Post New Thread
Threads in Forum : 1st Gen Hangout Forum Tools Search this Forum
  Rating Thread / Thread Starter Last Post Reverse Sort Order Replies Views
 
2 Attachment(s) Sticky Thread Sticky: 1st Gen FAQ...PLEASE READ. ADD INPUT (Multi-page thread 1 2 3 ... Last Page)
Couldn't open specs.. And mine is an
11-26-2014 08:43 PM
by Oregon541 Last Post
137 109,752
 
9 Attachment(s) Sticky Thread Sticky: Knock Sensor Relocation (How-To) (Multi-page thread 1 2 3 ... Last Page)
Could someone please post a link to the
10-23-2014 11:23 PM
by CamoFrontier01 Last Post
404 219,115
 
7 Attachment(s) Sticky Thread Sticky: Timing belt 3.3 V6 (Multi-page thread 1 2 3 ... Last Page)
Local dealer just quoted me $922 which
09-29-2014 04:46 PM
by 2010SE Last Post
177 122,538
Thumbs up
New person here ... six years after
06-17-2014 11:50 AM
by hallogallo Last Post
105 49,719
 
2 Attachment(s) Sticky Thread Sticky: Items for sale!! (Multi-page thread 1 2 3 ... Last Page)
Used 00-04 tail lights, small crack in
05-10-2014 02:06 PM
by frontier305 Last Post
38 28,712
 
And so it is. ...stuck. :)
12-20-2010 01:41 PM
by igbar Last Post
1 20,789
 
Sticky Thread Sticky: Hardbody and 1st gen axle info
source
10-23-2008 05:32 PM
by igbar Last Post
1 17,180
 
Vaughn Gittin Jr as Ricky Bobby? See how it happened [VIDEO]
Nitto Tire
Sponsored Post
by Nitto Tire Go to last post
- -
 
Today my truck started a knock /
11-26-2014 09:04 PM
by Plan B Last Post
0 89
 
04, xe, 3.3, v6, crew cab, 2wd, short
11-26-2014 05:35 PM
by Oregon541 Last Post
0 74
 
2 Attachment(s) DieHard batteries (Multi-page thread 1 2 3 )
You're welcome! Hope you get good
11-26-2014 02:16 PM
by HeavyG Last Post
24 768
 
and more
11-25-2014 05:55 PM
by redv6 Last Post
10 625
 
I never had a problem on my 95 KC XE
11-23-2014 09:07 PM
by Zero Six LE Last Post
5 201
 
each engine will have there own but
11-23-2014 06:33 PM
by Catlin Wolfe Last Post
0 96
 
4 Attachment(s) My '99 Frontier (Multi-page thread 1 2 3 ... Last Page)
Got my Idler Arm Brace installed and
11-23-2014 01:07 PM
by BlueSteel Last Post
163 25,808
 
it runs rough and obviously loses power
11-22-2014 03:05 PM
by sushidor Last Post
2 145
 
make sure you actually pack them, so
11-22-2014 02:35 AM
by redv6 Last Post
26 9,301
 
yeah it takes a few days to feel normal
11-20-2014 08:48 PM
by shakedownstreet Last Post
14 680
 
2002 lacking power (Multi-page thread 1 2 3 )
That is a harsh assessment, but I
11-20-2014 02:00 PM
by Billy D Last Post
24 1,071
 
Thanks mine is 4x4 so just thinking if
11-20-2014 12:29 PM
by bajatrailrider Last Post
2 159
 
Help, truck won't start (Multi-page thread 1 2 )
wet plugs and the computer needed a few
11-19-2014 08:04 PM
by shizzy Last Post
18 490
 
Anyone got one of these cam assembly's
11-18-2014 05:02 PM
by RxRC Last Post
8 727
 
Door lock switch/keyfob not working (Multi-page thread 1 2 )
Hi all I replaced the fuse at the
11-18-2014 01:13 PM
by hdfrontier Last Post
13 1,715
 
I would say check all of the fuses
11-16-2014 06:04 PM
by jerryp58 Last Post
1 334
 
haynes or chilton? (Multi-page thread 1 2 3 ... Last Page)
I wouldn't disagree that the
11-16-2014 12:20 PM
by HeavyG Last Post
42 3,985
Poll
Poll: How tall are 1st Gen Owners? (Multi-page thread 1 2 3 )
im the only one whos in my truck when i
11-14-2014 01:56 AM
by luke9511 Last Post
21 1,038
 
I've got the clockspring installed now
11-13-2014 07:04 PM
by Frontier.Steve Last Post
7 583
 
UPDATE: So I didn't really have time
11-13-2014 09:51 AM
by Exodus5 Last Post
3 265
Post New Thread

Display Options
Showing threads 1 to 20 of 6466
 
Forum Tools Search this Forum
Mark This Forum Read
View Parent Forum
Search this Forum :

Advanced Search

New posts New posts More than 15 replies or 150 views Hot thread with new posts
No new posts No new posts No new posts Hot thread with no new posts
Closed Thread Thread is closed  

 

Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off