Cam Sensor Replacement - Nissan Frontier Forum
 
LinkBack Thread Tools Display Modes
#1 (permalink) Old 06-11-2011, 09:11 PM
Shift_Enthusiast
 
BRBnismo's Avatar
 
Join Date: Jun 2008
Location: Ormond Beach FL
Posts: 232
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Cam Sensor Replacement

Hey Guys, I've been searching around and cant find much on replacing the bank one cam sensor, got the code for it 2 weeks ago, stalled a couple times and rough running at speed. I'm going to replace it tomorrow, it's on the passenger side (bank 1) and looks pretty difficult to get to, any suggestions?

I'll probably take pictures and do a write up when i get the chance.

Thanks

2005 KC 2x4. PRO COMP 7089, 265/70/r17 Nitto Terra Grapplers,Spectra intake,Flowmaster 50 series,Alpine MRP-M1000,Pioneer TS-W253R 10",DIY Aux Input,Custom Black Grill, UWS Black Low Profile Tool Box, Beltronics RX-65 Radar Detector
BRBnismo is offline  
Sponsored Links
Advertisement
 
#2 (permalink) Old 06-12-2011, 03:42 PM
Shift_lurker
 
Join Date: Jan 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
Same question from me actually. I've had the code P0340 thrown at me a few times in past couple weeks from my 2005 Frontier with 130k. It has died on me while driving and is unpredictable starting cold and hot.

I've gotten the intake plenum off but I still cant see the camshaft position sensor! There is a white connector visible from behind the valve cover (between the engine and firewall on the passenger side) but I'm still unsure if that is the correct sensor since all I can see is a connector.

Any one else tried to replace this?
Attached Thumbnails
Click image for larger version

Name:	Camshaft POS.JPG
Views:	4910
Size:	72.8 KB
ID:	32346  
shoedoob is offline  
#3 (permalink) Old 06-12-2011, 05:35 PM
Shift_Enthusiast
 
BRBnismo's Avatar
 
Join Date: Jun 2008
Location: Ormond Beach FL
Posts: 232
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
I think you should be able to see it with the plenum off, but I'm not sure. Anyone.....bump.....

2005 KC 2x4. PRO COMP 7089, 265/70/r17 Nitto Terra Grapplers,Spectra intake,Flowmaster 50 series,Alpine MRP-M1000,Pioneer TS-W253R 10",DIY Aux Input,Custom Black Grill, UWS Black Low Profile Tool Box, Beltronics RX-65 Radar Detector
BRBnismo is offline  
#4 (permalink) Old 06-12-2011, 06:19 PM
Shift_Hardcore
 
rdrfronty's Avatar
 
Join Date: Sep 2007
Posts: 1,604
Thanks: 48
Thanked 187 Times in 140 Posts
Feedback Score: 0 reviews
The cam sensors are on the back of the heads. Visualize where the cams sit and where the back of them point to. Thats where they sit stuck in a hole in the back of the heads. fairly easy to get out, but the wire connector is a tricky SOB to get off. There is a single bolt holding them in place.
Note the red circles on the photo. Thats where they sit when installed, poked in from the back side of course.
Attached Thumbnails
Click image for larger version

Name:	PC260050.JPG
Views:	9318
Size:	514.0 KB
ID:	32351  

2008 Frontier SE KC 4X2 6 Speed
Performance Mods-Uprev Dyno Tuned, Brian Crower Stage 2 Cams, 350Z Upper & Lower Plenums, Custom Mid-intake, Motordyne 5/16" Spacer, Truetrac LSD, 4.11 Gears, OBX Headers, True Duals w/Magnaflow Mufflers, & X-Pipe, Custom Magnaflow Testpipes, Volant CAI, Nismo Thermostat, WRP CP, Mishimoto Catch Can, JWT Lightweight Flywheel & Clutch
Other Mods-Nismo 18" x 8.5" wheels, Dunlop Sport 265/60/18 tires, Morimoto Mini H1 5K HID Projectors
276 WHP & 288 FTLB--14.15 @ 95.88mph
rdrfronty is offline  
#5 (permalink) Old 06-12-2011, 08:15 PM
Shift_Enthusiast
 
BRBnismo's Avatar
 
Join Date: Jun 2008
Location: Ormond Beach FL
Posts: 232
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
Thanks rdr, it look like in shoedoob's diagram that the bank 1 sensor is on the black portion of the head but in your picture it's a hole in the aluminum rather than that black composite material?

2005 KC 2x4. PRO COMP 7089, 265/70/r17 Nitto Terra Grapplers,Spectra intake,Flowmaster 50 series,Alpine MRP-M1000,Pioneer TS-W253R 10",DIY Aux Input,Custom Black Grill, UWS Black Low Profile Tool Box, Beltronics RX-65 Radar Detector
BRBnismo is offline  
#6 (permalink) Old 06-12-2011, 09:06 PM
Shift_lurker
 
Join Date: Jan 2011
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
I finally got the connector off and the sensor replaced. The check engine light went off immediately!

Make sure you have the right cam sensor, the one I originally purchased had an angled connector which is for bank 2, the driver side. I picked up the correct sensor for bank 1 (passenger side) which has a straight connector.

I did have to take the plenum off but thankfully not the valve cover. All the wire harness and vacuum lines need to be loosened to get your hands and tools back there.

The image I attached is a little deceiving. Like the image rdr posted, the sensor faces the firewall and does not come out vertically. The connector was a super pain to get off, a spring type push-in release on the bottom side held it on and it took a lot of wiggling to get it to release.
shoedoob is offline  
#7 (permalink) Old 06-13-2011, 05:01 PM
Shift_Enthusiast
 
BRBnismo's Avatar
 
Join Date: Jun 2008
Location: Ormond Beach FL
Posts: 232
Thanks: 0
Thanked 4 Times in 4 Posts
Feedback Score: 0 reviews
I got it replaced today as well, did it without taking much of the manifold or plenum really, it still was a pain and I had to finagle some vacuum lines and wires to unbolt it, but hopefully the shaking stops, or it's back to the transmission shop that rebuilt my transmission due to the coolant issue....

2005 KC 2x4. PRO COMP 7089, 265/70/r17 Nitto Terra Grapplers,Spectra intake,Flowmaster 50 series,Alpine MRP-M1000,Pioneer TS-W253R 10",DIY Aux Input,Custom Black Grill, UWS Black Low Profile Tool Box, Beltronics RX-65 Radar Detector
BRBnismo is offline  
#8 (permalink) Old 08-29-2011, 11:10 PM
Shift_Newbie
 
BOBO_25's Avatar
 
Join Date: Jul 2008
Location: Green Bay, WI
Posts: 80
Thanks: 0
Thanked 0 Times in 0 Posts
Feedback Score: 0 reviews
if i am throwing p0340 how do you know with sensor it is A or B

_________________________________
2005 Nissan Frontier Crew Cab LE 4X4
BOBO_25 is offline  
#9 (permalink) Old 08-30-2011, 05:07 PM
Shift_Enthusiast
 
SON OF A SAILOR's Avatar
 
Join Date: Feb 2008
Location: Mall of GA
Posts: 351
Thanks: 28
Thanked 25 Times in 23 Posts
Feedback Score: 0 reviews
When you read the code, it will tell you right or left bank. I dont have a code reader any more of my own, but advance auto will read it for you for free.
As mentioned above I also bought the wrong one first. I assumed it was right and left standing in front of the truck with the hood up......Its not ....
As there is no room to easily change either one, I think they made them different just to mess with us. 1 is a 45 degree and the other is a 90?????

05 nismo 4x4 radiant silver CC v6.... I even got the invisible bra!
Drive it like I stole it, but changed the oil first

Life is tough....... it's even tougher if you're stupid.
SON OF A SAILOR is offline  
Reply

  Nissan Frontier Forum > Mods and Technical Discussions > DIY - Do It Yourself / Tech Tips

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Frontier Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On