let the fun begin:) - Page 4 - Nissan Frontier Forum
Reply
 
LinkBack Thread Tools Display Modes
#31 (permalink) Old 06-27-2011, 09:52 AM
Shift_Fanatic
 
xterra hines's Avatar
 
Join Date: Mar 2008
Posts: 738
Thanks: 1
Thanked 24 Times in 20 Posts
Feedback Score: 0 reviews
Quote:
Originally Posted by Speedy64i View Post
My turbo is tucked up under the bed right in front of the rear axle. I had alot of lag problems until i referenced the wastegate from the intake maifold after the throttle body. After i did that a few days ago, the turbo feels great, and the worst i can get it to overboost is from my set point of 5 psi to 5.8psi. I've been running an intercooler from the get go since i wanted to tow with this setup. It's a Mitsubishi EVO10 intercooler... works like a champ, worst case during hot WOT runs i get 15 to 20 degrees F above ambient temperature out of the intercooler.

JT
oh very nice! ya i learned referencing the wastegate from the mani is more benificial then the turbo. where is your maf located? what did you dyno at? and what are you running at the track?

here is the intercooler im using

Universal 25x11x3 1-Side 2.5" Inlet&Outlet Intercooler | eBay
and also what injectors did you go with?

First Turbo charged vq40.

SINGLE T4 TURBO, treadstone intercooler, tial 38mm wastegate, greddy type rs blow off valvle, arp head and main studs, port and polished heads, 9:1 compression, cp pistons, puater x beam connecting rods, uprev tuned. 550cc injecters, walbro 255gph fuel pump. level ten torque converter, high energy cluth pack, modded valve body.

7 psi, 417hp-451tq,

15 ps1 507 hp, 563 tq
xterra hines is offline  
Sponsored Links
Advertisement
 
#32 (permalink) Old 06-27-2011, 10:38 AM
Shift_lurker
 
Join Date: Nov 2008
Posts: 29
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
I wish I would have realized that referencing from the manifold wouldnt be an overboost problem earlier! It feels WAY better now.

My MAF is pretty much in the stock location. I dyno'd at Intec Racing in Seattle WA, but i was only getting 2-2.5 psi of boost with the setup i had there. The dyno said i was a little over 265HP and 285ft lbs. at the wheels. I have no idea what it's at now though since i'm boosting an full 5 (maybe 300hp and 320tq to the wheels, that extra 2.5 to 3 psi really helped though). Next time i can drive 10 hours to seattle, i'll probably have them re-dyno it and double check my tune since i changed it all around with the higher boost to keep the knock at bay. did you know the osiris ROM editor logs knock now? pretty cool!

I need to re-do the intake but it will require some tuning time and maybe an HPX MAF (i'm hitting 4.8v on my MAF right now); I'll probably go back to Intec Racing for that. When i got this thing tuned there, my first set of injectors had one bad... it ended up getting stuck full open during a WOT dyno pull and scared the crap out of everyone, most of all me... Grey smoke, dropping cylinders at WOT, tons of fluid in the cylinder, thank god it turned out to be gas and not oil... I thought it was done. But everything turned out good now! The pistons were fine and luckily it didn't hydro lock on shutdown. I'll be taking the same route as you eventually, but an engine rebuild isnt on my short term list, although i'd REALLY love to sooner than later!

I don't track the truck, i have a twin turbo Mitsubishi 3000GT for that . my whole goal with the truck is to just get reliable power so I can pull my trailer shaped wind brake with a headwind up the mountains around here.

I am running DeatschWerks 600cc injectors with a Walbro 255LPH Pump. The nissan 350Z ones they make are a direct drop in.

JT

2009 Frontier Pro-4X, STS Turbo @ 5 psi, UpRev Tuned, Intercooled, MAP Conversion, Walbro 255lph Fuel Pump, 600cc Injectors, KnockLite :P, LT Headers, Flowmaster 70 Series 3" Exhaust, Deaver 10 Leaf Rear Springs, Billstein Rear Shocks, Radflo 2.5" Front Shocks w/600# Eibach Springs, PRG UCA, 19 gal. Aux Fuel Tank, 800W Inverter, Firestone Air Bags, GenK51a HomeLink Mirror, Scangauge II... and the list keeps growing
Speedy64i is offline  
#33 (permalink) Old 06-27-2011, 02:41 PM
Shift_Fanatic
 
xterra hines's Avatar
 
Join Date: Mar 2008
Posts: 738
Thanks: 1
Thanked 24 Times in 20 Posts
Feedback Score: 0 reviews
you know whats funny, my injectors did the same thing. 2 of the new injectors i got(550cc) where bad and stuck open. i was really scared lol but xact dyno got me new ones in no time. i think you should be making more then 300 hp. on 6 psi i made 360hp to the hubs. on my old threads i have the dyno sheets posted up. i have my maf sensor before the turbo. i did this for a couple reasons. all turbos will blow a little oil into the charge pipe at times. which might mess with the maf readings, and also its thought that drivabitily will be better due to less air turbulence before the compressor. i maxed out my maf at 8psi. it was reaching a full 5v there so i will need the hpx maf when i get it tuned.

i did see the knock thingy on uprevs site. thats pretty sweet! i do drag the x every now and then. its fun to see peoples faces when they see me staging at the track. it ran 12.96 at 114 last time i had it out on 8 psi with the stock trans and motor. im hoping for 11's on 14psi

First Turbo charged vq40.

SINGLE T4 TURBO, treadstone intercooler, tial 38mm wastegate, greddy type rs blow off valvle, arp head and main studs, port and polished heads, 9:1 compression, cp pistons, puater x beam connecting rods, uprev tuned. 550cc injecters, walbro 255gph fuel pump. level ten torque converter, high energy cluth pack, modded valve body.

7 psi, 417hp-451tq,

15 ps1 507 hp, 563 tq
xterra hines is offline  
#34 (permalink) Old 06-27-2011, 03:19 PM
Shift_Obsessed
Lifetime Member
 
jhughes3281's Avatar
 
Join Date: Oct 2008
Location: Santee, CA
Posts: 4,064
Thanks: 131
Thanked 489 Times in 338 Posts
Feedback Score: 3 reviews
Hey speedy...can you post some pics of your setup?

I work because somebody has to pay for all the lifelong welfare entitlements. Redistributionomics 101
jhughes3281 is offline  
#35 (permalink) Old 06-27-2011, 03:23 PM
Shift_Enthusiast
 
Join Date: Mar 2006
Location: Litchfield Park, AZ
Posts: 208
Thanks: 1
Thanked 2 Times in 2 Posts
Feedback Score: 0 reviews
Aaron,

Well I guess it was a good thing that I bugged you to see where you were at. This is great news to hear that you are finally ready to get the X back on the road.

Pictures will be nice to see.

I'm sure you will not be running it too hard with our 114 degree temps that we are experiencing right now.

2005 2WD CC SE Avalanche White - Added XPBQN Infiniti FX-R HID Projector 5000K retrofit, Airaid Cold Air, JBA catback, chrome door handles and mirrors, factory foglights, Pathfinder window switch covers, Alpine 9857, RF 450.4, MTX Thunderform enclosure, Infinity Kappa speakers, complete SecondSkin Audio sound deadening to floor, doors, and roof
sundevilfanatic is offline  
#36 (permalink) Old 06-27-2011, 04:03 PM
Shift_Fanatic
 
xterra hines's Avatar
 
Join Date: Mar 2008
Posts: 738
Thanks: 1
Thanked 24 Times in 20 Posts
Feedback Score: 0 reviews
ya its so hot right now. and no ill be keeping it safe in the day, maybe at night ill open it up then. we need rain so bad, i cant wait for those monsoons to come!

First Turbo charged vq40.

SINGLE T4 TURBO, treadstone intercooler, tial 38mm wastegate, greddy type rs blow off valvle, arp head and main studs, port and polished heads, 9:1 compression, cp pistons, puater x beam connecting rods, uprev tuned. 550cc injecters, walbro 255gph fuel pump. level ten torque converter, high energy cluth pack, modded valve body.

7 psi, 417hp-451tq,

15 ps1 507 hp, 563 tq
xterra hines is offline  
#37 (permalink) Old 06-27-2011, 05:54 PM
Shift_lurker
 
Join Date: Nov 2008
Posts: 29
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
lol, man i'd like to think the injectors don't get stuck open like that all the time, but 3 injectors between the two of us? yikes!

I'll have to get it dyno'd again when i can get back to one... the closest dyno is 3 hours away. all i know right now is that from a roll on with the vdc off, the tires will lite up at about 15 mph.

My maf readings seem pretty stable, but i do plan on re-doing the intake with a honeycomb in front of the MAF. I have all the parts but i'll need to re-do the tune and i dont have the time to do it before i have to go on a trip with my trailer. I do have a tiny bit of oil sheen on my maf from when i decided to test the oil pressure buzzer sts includes with the kit. i got alot of oil in my intake in a very short time without the scavenge pump on, lol.. but like i said so far it seems very stable.

I might take the truck to the strip sometime, but the closest strip is 2.5 hours away from me too... nothing is close

I'll see what i can do about some pics jhughes, all the ones i have right now are of an incomplete truck, but i'll post them in a few.

JT

2009 Frontier Pro-4X, STS Turbo @ 5 psi, UpRev Tuned, Intercooled, MAP Conversion, Walbro 255lph Fuel Pump, 600cc Injectors, KnockLite :P, LT Headers, Flowmaster 70 Series 3" Exhaust, Deaver 10 Leaf Rear Springs, Billstein Rear Shocks, Radflo 2.5" Front Shocks w/600# Eibach Springs, PRG UCA, 19 gal. Aux Fuel Tank, 800W Inverter, Firestone Air Bags, GenK51a HomeLink Mirror, Scangauge II... and the list keeps growing
Speedy64i is offline  
#38 (permalink) Old 06-27-2011, 06:09 PM
Shift_lurker
 
Join Date: Nov 2008
Posts: 29
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
Pics

Here's the front with the intercooler, the intake pipe you can barely see in the engine bay is back using the stock plastic pipe for now.


This is underneath the truck... again it's doesnt look quite like this anymore, the filter was relocated in the truck bed next to my 19 gal aux tank. It was getting too much water and nastiness on it down there.


Here's a pic of the truck with the front bumper off, i had to relocate the lower bolts of the transmission cooler to behind the rail in front of the radiator to fit the intercooler. i also had to relocate what i think is one of the crash sensors on the front of the truck.


lol, like i said, they are all older photos and there are minor changes since i took them. but you guys get the idea.

JT

2009 Frontier Pro-4X, STS Turbo @ 5 psi, UpRev Tuned, Intercooled, MAP Conversion, Walbro 255lph Fuel Pump, 600cc Injectors, KnockLite :P, LT Headers, Flowmaster 70 Series 3" Exhaust, Deaver 10 Leaf Rear Springs, Billstein Rear Shocks, Radflo 2.5" Front Shocks w/600# Eibach Springs, PRG UCA, 19 gal. Aux Fuel Tank, 800W Inverter, Firestone Air Bags, GenK51a HomeLink Mirror, Scangauge II... and the list keeps growing
Speedy64i is offline  
#39 (permalink) Old 06-28-2011, 03:00 AM
Shift_Fanatic
 
xterra hines's Avatar
 
Join Date: Mar 2008
Posts: 738
Thanks: 1
Thanked 24 Times in 20 Posts
Feedback Score: 0 reviews
nice pics! but i would highly rec. putting the muffler after the turbo. turbos work off of exhaust velocity, that the baffled muffler is killing velocity. also what are you doing to block the crankcase from seeing boost? doesnt the stock black intake have a open fitting for fresh air to the valve cover?

First Turbo charged vq40.

SINGLE T4 TURBO, treadstone intercooler, tial 38mm wastegate, greddy type rs blow off valvle, arp head and main studs, port and polished heads, 9:1 compression, cp pistons, puater x beam connecting rods, uprev tuned. 550cc injecters, walbro 255gph fuel pump. level ten torque converter, high energy cluth pack, modded valve body.

7 psi, 417hp-451tq,

15 ps1 507 hp, 563 tq
xterra hines is offline  
#40 (permalink) Old 06-28-2011, 04:09 AM
Shift_lurker
 
Join Date: Nov 2008
Posts: 29
Thanks: 0
Thanked 3 Times in 2 Posts
Feedback Score: 0 reviews
yeah i thought that too untill i put a test pipe in there and realized it didn't make near the difference i thought it would, the boost reference was my issue with boost lag. Also, that muffler doesnt have baffles, it's a straight tube with perforated holes so it's more like a resonator. the down side is that it is like adding another 20 feet of exhaust pipe volume wise the good news is that the extra volume only takes an extra tenth of a second to fill compared to pipe only.

I have the parts to redo the exhaust, but i decidd to hold off on that since it's just running so nice now!

The crankcase is totally isolated from the intake, it's just vented to atmosphere now and the stock black intake is capped.

2009 Frontier Pro-4X, STS Turbo @ 5 psi, UpRev Tuned, Intercooled, MAP Conversion, Walbro 255lph Fuel Pump, 600cc Injectors, KnockLite :P, LT Headers, Flowmaster 70 Series 3" Exhaust, Deaver 10 Leaf Rear Springs, Billstein Rear Shocks, Radflo 2.5" Front Shocks w/600# Eibach Springs, PRG UCA, 19 gal. Aux Fuel Tank, 800W Inverter, Firestone Air Bags, GenK51a HomeLink Mirror, Scangauge II... and the list keeps growing
Speedy64i is offline  
Reply

  Nissan Frontier Forum > Mods and Technical Discussions > Performance Mods

Quick Reply
Message:
Options

Register Now

In order to be able to post messages on the Nissan Frontier Forum forums, you must first register.
Please enter your desired user name, your email address and other required details in the form below.
User Name:
If you do not want to register, fill this field only and the name will be used as user name for your post.
Password
Please enter a password for your user account. Note that passwords are case-sensitive.
Password:
Confirm Password:
Email Address
Please enter a valid email address for yourself.
Email Address:

Log-in

Human Verification

In order to verify that you are a human and not a spam bot, please enter the answer into the following box below based on the instructions contained in the graphic.




Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Show Printable Version Show Printable Version
Email this Page Email this Page
Display Modes
Linear Mode Linear Mode



Posting Rules  
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On